git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 01/11] builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()

From
Jeff King <peff@peff.net>
Date
Mar 1, 2014, 07:07 UTC
Message-ID
<20140301070758.GE20397@sigill.intra.peff.net>
In-Reply-To
<xmqqfvn3ukjs.fsf@gitster.dls.corp.google.com>
On Fri, Feb 28, 2014 at 11:03:19AM -0800, Junio C Hamano wrote:
Show 14 quoted lines
> Michael Haggerty <mhagger@alum.mit.edu> writes:
> 
> > So my vote is that the patches are OK the way Dmitry wrote them (mind, I
> > have only read through 05/11 so far).
> 
> Seconded ;-)
> 
> By the way, I do not like these long subjects.  "change" is a
> redundant word when one sends a patch---as all patches are about
> changing something.
> 
> 	Subject: builtin/pack-objects.c: use ALLOC_GROW() in check_pbase_path()
> 
> would be a lot more appropriate for "git shortlog" consumption.

I would actually go one step further and drop or shorten the filename in the subject. It is very long, it is already easy to see which file was changed from the diffstat, and it doesn't give any useful context for other parts of the subject.

I really like the "foo:" convention for starting a subject line, because it immediately makes clear what area you are working in without having to waste space on English conjunctions or prepositions. But it does not have to be a filename. It can be a subsystem, a command, a function, an area of the project, or anything that gives context to the rest of the line.

So I would suggest one of:
  Subject: use ALLOC_GROW() in check_pbase_path()
    Talking about the filename is redundant; there's only one
    check_pbase_path.
  Subject: check_pbase_path: use ALLOW_GROW
    Even shorter.
  Subject: builtin/pack-objects.c: use ALLOC_GROW
    This one implies to me that the point of the commit is to convert
    the whole file to use ALLOC_GROW where appropriate, not just that
    function (even if that function may be the only spot changed).
I'd probably not use:
  Subject: pack-objects: use ALLOC_GROW
as the scope is not about the command, but about the C file.

I realize that I just bikeshedded on subject lines for half a page, and part of me wants to go kill myself in shame. But I feel like I see the technique misapplied often enough that maybe some guidance is merited. Feel free to ignore. :)

-Peff
Previous: Junio C HamanoNext: Junio C Hamano
Message 11 of 42 in “Use ALLOC_GROW() instead of inline code”
  1. Use ALLOC_GROW() instead of inline codeDmitry S. Dolzhenko, Feb 27, 2014
  2. Michael HaggertyFeb 27, 2014
  3. Junio C HamanoFeb 27, 2014
  4. 00/11 Use ALLOC_GROW() instead of inline codeDmitry S. Dolzhenko, Feb 28, 2014
  5. 01/11 builtin/pack-objects.c: change check_pbase_path() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  6. Duy NguyenFeb 28, 2014
  7. Duy NguyenFeb 28, 2014
  8. Michael HaggertyFeb 28, 2014
  9. Duy NguyenFeb 28, 2014
  10. Junio C HamanoFeb 28, 2014
  11. Jeff KingMar 1, 2014
  12. Junio C HamanoMar 3, 2014
  13. 02/11 bundle.c: change add_to_ref_list() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  14. 03/11 cache-tree.c: change find_subtree() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  15. 04/11 commit.c: change register_commit_graft() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  16. 05/11 diff.c: use ALLOC_GROW() instead of inline codeDmitry S. Dolzhenko, Feb 28, 2014
  17. 06/11 diffcore-rename.c: use ALLOC_GROW() instead of inline codeDmitry S. Dolzhenko, Feb 28, 2014
  18. 07/11 patch-ids.c: change add_commit() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  19. 08/11 replace_object.c: change register_replace_object() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  20. 09/11 reflog-walk.c: use ALLOC_GROW() instead of inline codeDmitry S. Dolzhenko, Feb 28, 2014
  21. Duy NguyenFeb 28, 2014
  22. Junio C HamanoFeb 28, 2014
  23. 10/11 dir.c: change create_simplify() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  24. 11/11 attr.c: change handle_attr_line() to use ALLOC_GROW()Dmitry S. Dolzhenko, Feb 28, 2014
  25. Michael HaggertyFeb 28, 2014
  26. Dmitry S. DolzhenkoMar 1, 2014
  27. Junio C HamanoMar 3, 2014
  28. 00/11 Use ALLOC_GROW() instead of inline codeDmitry S. Dolzhenko, Mar 3, 2014
  29. 01/11 builtin/pack-objects.c: use ALLOC_GROW() in check_pbase_path()Dmitry S. Dolzhenko, Mar 3, 2014
  30. 02/11 bundle.c: use ALLOC_GROW() in add_to_ref_list()Dmitry S. Dolzhenko, Mar 3, 2014
  31. 03/11 cache-tree.c: use ALLOC_GROW() in find_subtree()Dmitry S. Dolzhenko, Mar 3, 2014
  32. 04/11 commit.c: use ALLOC_GROW() in register_commit_graft()Dmitry S. Dolzhenko, Mar 3, 2014
  33. 05/11 diff.c: use ALLOC_GROW()Dmitry S. Dolzhenko, Mar 3, 2014
  34. 06/11 diffcore-rename.c: use ALLOC_GROW()Dmitry S. Dolzhenko, Mar 3, 2014
  35. 07/11 patch-ids.c: use ALLOC_GROW() in add_commit()Dmitry S. Dolzhenko, Mar 3, 2014
  36. 08/11 replace_object.c: use ALLOC_GROW() in register_replace_object()Dmitry S. Dolzhenko, Mar 3, 2014
  37. 09/11 reflog-walk.c: use ALLOC_GROW()Dmitry S. Dolzhenko, Mar 3, 2014
  38. 10/11 dir.c: use ALLOC_GROW() in create_simplify()Dmitry S. Dolzhenko, Mar 3, 2014
  39. 11/11 attr.c: use ALLOC_GROW() in handle_attr_line()Dmitry S. Dolzhenko, Mar 3, 2014
  40. Eric SunshineMar 3, 2014
  41. Junio C HamanoMar 3, 2014
  42. He SunMar 3, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.