Re: [PATCH 12/20] alias: trivial style fix
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Oct 14, 2013, 14:18 UTC
- Message-ID
- <20131014141806.GB21200@google.com>
- In-Reply-To
- <52590E97.6060308@googlemail.com>
Stefan Beller wrote:
> On 10/12/2013 09:07 AM, Felipe Contreras wrote:
>> Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com> > > Not sure if it's worth by a newcomer. ;)
A second set of eyes is always welcome.
My thoughts: I have to admit I don't see much value in mechanical replacements like this one when done piecemeal and without other more significant changes on top. If this was fixing some particular eyesore, I would understand, and a little preparatory cleanup to make another patch on top more readable is always welcome, but this kind of thing:
Show 8 quoted lines
>> --- a/alias.c
>> +++ b/alias.c
>> @@ -5,7 +5,7 @@ static char *alias_val;
>>
>> static int alias_lookup_cb(const char *k, const char *v, void *cb)
>> {
>> - if (!prefixcmp(k, "alias.") && !strcmp(k+6, alias_key)) {
>> + if (!prefixcmp(k, "alias.") && !strcmp(k + 6, alias_key)) {does not look worth the churn and mailing list noise to me.
A patch that globally took care of these var+constant constructs without surrounding space and did nothing else, once and for all to avoid later noise, may or may not be useful. I suspect even that wouldn't be worth it, since "k+6" already seems perfectly readable.
So, not too excited by this change.
Hope that helps, Jonathan