Re: the pager
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Sep 3, 2013, 02:57 UTC
- Message-ID
- <20130903025711.GA25617@elie.Belkin>
- In-Reply-To
- <201309030227.r832RmBd013888@freeze.ariadne.com>
Hi,
Dale R. Worley wrote:
Show 9 quoted lines
> That's true, but it would change the effect of using "cat" as a value: > "cat" as a value of DEFAULT_PAGER would cause git_pager() to return > NULL, whereas now it causes git_pager() to return "cat". (All other > places where "cat" can be a value are translated to NULL already.) > > This is why I want to know what the *intended* behavior is, because we > might be changing Git's behavior, and I want to know that if we do > that, we're changing it to what it should be. And I haven't seen > anyone venture an opinion on what the intended behavior is.
I don't really follow.
For all practical purposes, "cat" is equivalent to no pager at all, no? And the git-var(1) manpage describes the intended order of precedence, as far as I can tell, except that it was written before v1.7.4-rc0~76^2 (allow command-specific pagers in pager.<cmd>, 2010-11-17) which forgot to update some documentation.
Suggested wording for improving the documentation or its organization would of course be welcome. And I agree with Matthieu that the name of the pager_program global variable is needlessly confusing --- perhaps it should be called config_pager_program or similar.
Thanks, Jonathan