Re: [PATCH] commit: correct advice about aborting a cherry-pick
- From
Jeff King <peff@peff.net>
- Date
- Jul 29, 2013, 15:23 UTC
- Message-ID
- <20130729152345.GA10393@sigill.intra.peff.net>
- In-Reply-To
- <7vtxjd1jje.fsf@alter.siamese.dyndns.org>
On Mon, Jul 29, 2013 at 08:18:45AM -0700, Junio C Hamano wrote:
Show 14 quoted lines
> > if (file_exists(git_path("MERGE_HEAD")))
> > whence = FROM_MERGE;
> > - else if (file_exists(git_path("CHERRY_PICK_HEAD")))
> > + else if (file_exists(git_path("CHERRY_PICK_HEAD"))) {
> > whence = FROM_CHERRY_PICK;
> > + if (file_exists(git_path("sequencer")))
> > + sequencer_in_use = 1;
>
> Should this be
>
> sequencer_in_use = file_exists(...)
>
> so readers do not have to wonder what the variable is initialized
> to?Yeah, I think that is a readability improvement. I suppose the use-site could also just run "file_exists" itself, but I wanted to keep the filesystem-reading "magic name" bits together.
I had also originally considered adding new states to "whence" to cover these cases (i.e., FROM_CHERRY_PICK_MULTI), but there are fallouts all over the place for call sites that do not care whether we are in the single- or multi-commit mode.
-Peff