Re: [PATCH 6/6] http: rename HTTP_REAUTH to HTTP_AUTH_RETRY
- From
Jeff King <peff@peff.net>
- Date
- May 4, 2012, 07:25 UTC
- Message-ID
- <20120504072556.GF21895@sigill.intra.peff.net>
- In-Reply-To
- <4FA2B508.8000702@seap.minhap.es>
On Thu, May 03, 2012 at 06:40:40PM +0200, Nelson Benitez Leon wrote:
> After adding the proxy authentication support in http, the semantics > of HTTP_REAUTH changed more to a retry rather than a re-authentication, > so we rename it to HTTP_AUTH_RETRY.
The patch looks fine, but a minor nit on the rationale. It has nothing to do with the proxy auth. It has always been a bad name. It is not "you should re-authenticate", but rather "I have already re-authenticated, and therefore you should call me again to retry".
-Peff