Re: [PATCH 2/9] t7006: test pager configuration for several git commands
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Apr 13, 2010, 22:07 UTC
- Message-ID
- <20100413220737.GA1676@progeny.tock>
- In-Reply-To
- <4BC4107E.20101@viscovery.net>
Johannes Sixt wrote:
Show 9 quoted lines
> The intents of the test cases would be much easier to follow and to review > if this were written as, for example: > > test_default_pager 'git log' > test_PAGER_overrides 'git log' > test_core_pager_overrides 'git log' > test_core_pager_subdir 'git log' > test_GIT_PAGER_overrides 'git log' > test_default_pager 'git -p log'
[...]
Good idea. This would also make the expected result much easier to change test-by-test. Will do, thanks.
Jonathan