Re: [RFC PATCH] Implement unstage and reset modes for git-add--interactive
- From
Thomas Rast <trast@student.ethz.ch>
- Date
- Jul 24, 2009, 23:17 UTC
- Message-ID
- <200907250117.31847.trast@student.ethz.ch>
- In-Reply-To
- <20090725065822.6117@nanako3.lavabit.com>
Nanako Shiraishi wrote:
Show 15 quoted lines
> Quoting Junio C Hamano <gitster@pobox.com> > > > "resetting index entries selectively" makes perfect sense. So do > > "checking out index entries selectively" and "adding to index > > selectively". > > Are you saying that you are fine with the concept of Thomas'es patch > series but you don't want to see different words used to name these > operations? > > In other words, do you mean the following would be a pair of better > companions to "git add -p $file" than Thomas'es discard and unstage? > > - "git checkout -p $file" and "git checkout -p $commit $file" [...] > - "git reset -p $file" and "git reset -p $commit $file" [...]
I'd be quite interested to hear some opinions on this. I wasn't sure what to do and eventually opted for unstage/discard because I felt 'git checkout -p $file' was not an accurate description of what it does, but maybe I just have the mental blocks in the wrong places.
--
Thomas Rast
trast@{inf,student}.ethz.ch