git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [JGIT PATCH 09/13] Replace inefficient new String(String) constructor to silence FindBugs

From
Shawn O. Pearce <spearce@spearce.org>
Date
Apr 29, 2009, 20:22 UTC
Message-ID
<20090429202242.GI23604@spearce.org>
In-Reply-To
<200904292210.49627.robin.rosenberg.lists@dewire.com>
Robin Rosenberg <robin.rosenberg.lists@dewire.com> wrote:
Show 6 quoted lines
> tisdag 28 april 2009 23:12:22 skrev "Shawn O. Pearce" <spearce@spearce.org>:
> > FindBugs keeps reporting that our usage of new String(String)
> > is not the most efficient way to construct a string.
> 
> I think we should find better ways of silencing FindBugs,, than addiing obscure
> coding patterns that are worse than what FindBugs warns against. 

Heh. Yea, well... I also wasn't too happy with FindBugs for this one.

As far as I can tell there isn't anything in the documentation that suggests that new String(String) behaves the way I want it to here.

It seems a JRE may be free to reuse the same internal char[] as the source string, and just produce a new String wrapper. What I really want is a deep copy of that char[] to shed what I know is garbage around the interesting part.

The use of StringBuilder makes this sort of anti-optimization more difficult, as most JRE implementations would likely assume they should alloc the internal char[] at the size given in the constructor, and will deep-copy the chars during append(String,int,int) because they would expect to see more characters appended after this append call.

Perhaps the only way to really enforce the behavior I want here is to convert the String segment to a char[], and then convert that char[] into a String. Ick, that's two copies.

Maybe we just stick a comment here.  Two different people have
come up with the same FindBugs issue, trying to get them to share
configuration files sounds hard.
 
> Options are: 
> 	Add a comment 
> 	Customize findbugs rules
> 	Findbugs specific annotations
-- 
Shawn.
Previous: Robin Rosenberg
Message 18 of 18 in “Misc. bug fixes and cleanups”
  1. 00/13 Misc. bug fixes and cleanupsShawn O. Pearce, Apr 28, 2009
  2. 01/13 Fix performance problem recently introduced to DeltaPackedObjectLoaderShawn O. Pearce, Apr 28, 2009
  3. 02/13 Don't use ByteWindows when checking pack file headers/footersShawn O. Pearce, Apr 28, 2009
  4. 03/13 Rewrite WindowCache to be easier to follow and maintainShawn O. Pearce, Apr 28, 2009
  5. 04/13 Document the IllegalArgumentException thrown by WindowCache.reconfigureShawn O. Pearce, Apr 28, 2009
  6. 05/13 Create the new WindowCache before clearing the old oneShawn O. Pearce, Apr 28, 2009
  7. 06/13 Better handle concurrent reads during a WindowCache reconfigurationShawn O. Pearce, Apr 28, 2009
  8. 07/13 Clear dead OffsetCache cells when clearing a referenceShawn O. Pearce, Apr 28, 2009
  9. 08/13 Work around Sun JVM bug "Cleared SoftReference not added to queue"Shawn O. Pearce, Apr 28, 2009
  10. 09/13 Replace inefficient new String(String) constructor to silence FindBugsShawn O. Pearce, Apr 28, 2009
  11. 10/13 Replace inefficient new Long(long) constructor to silence FindBugsShawn O. Pearce, Apr 28, 2009
  12. 11/13 Change IndexPack to use ObjectIdSubclassMap instead of ObjectIdMapShawn O. Pearce, Apr 28, 2009
  13. 12/13 Use getCachedBytes in IndexPack to avoid an unnecessary copyShawn O. Pearce, Apr 28, 2009
  14. 13/13 Remove ObjectIdMap from the JGit libraryShawn O. Pearce, Apr 28, 2009
  15. Robin RosenbergApr 29, 2009
  16. 12/11 Add a test for LongMap, IndexPack's helper classShawn O. Pearce, Apr 29, 2009
  17. Robin RosenbergApr 29, 2009
  18. Shawn O. PearceApr 29, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.