git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] {diff,merge}tool: rename helpers to remove them from tab-completion

From
Markus Heidelberg <markus.heidelberg@web.de>
Date
Apr 2, 2009, 20:04 UTC
Message-ID
<200904022204.34019.markus.heidelberg@web.de>
In-Reply-To
<1238672296-10265-1-git-send-email-davvid@gmail.com>
David Aguilar, 02.04.2009:
> diff --git a/Makefile b/Makefile
[..]
Show 7 quoted lines
>  SCRIPT_SH += git-merge-resolve.sh
>  SCRIPT_SH += git-mergetool.sh
> -SCRIPT_SH += git-mergetool-lib.sh
> +SCRIPT_SH += git-mergetool--lib.sh
>  SCRIPT_SH += git-parse-remote.sh
>  SCRIPT_SH += git-pull.sh
>  SCRIPT_SH += git-quiltimport.sh

This conflicts with commit 496c021 (Add a script to edit/inspect notes) in 'pu', which seems to be just merged today. If you build your patches on top of 'da/difftool' (99511d8) instead of 'pu', then these conflicts won't arise and avoid hassle.

In fact I already applied all your patches on top 'da/difftool' and not 'pu' all the time, until now.

Thanks for your work on this
Markus
Previous: David Aguilar
Message 2 of 2 in “{diff,merge}tool: rename helpers to remove them from tab-completion”
  1. {diff,merge}tool: rename helpers to remove them from tab-completionDavid Aguilar, Apr 2, 2009
  2. Markus HeidelbergApr 2, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.