Re: [JGIT PATCH 3/3] Use a common skipObject method to avoid UNINTERESTING items
- From
Robin Rosenberg <robin.rosenberg.lists@dewire.com>
- Date
- Mar 15, 2009, 00:25 UTC
- Message-ID
- <200903150125.56987.robin.rosenberg.lists@dewire.com>
- In-Reply-To
- <1236967912-15088-3-git-send-email-spearce@spearce.org>
fredag 13 mars 2009 19:11:52 skrev "Shawn O. Pearce" <spearce@spearce.org>:
> All cases are using the same logic to decide that we should skip > this current object and not return it to the caller. A common > implementation makes the code easier to follow, especially as it > reduces the ugly line wrap involved in the loop body.
Java conventions dictate that this method should be called shouldSkipObject. It is a boolean method that actually does not itself skip any objects.
I can amend that for you.
-- robin