Bug: /usr/local/bin/git-daemon starts /usr/sbin/git-upload-pack?
- From
- Jan Wielemaker <j.wielemaker@uva.nl>
- Date
- Jul 9, 2008, 20:20 UTC
- Message-ID
- <200807092220.10655.J.Wielemaker@uva.nl>
Hi,
After upgrade to SuSE 11.0 I was forced to update GIT (changed libcurl). I did (with some trickery) a pull of the latest git and built it using make prefix=/usr/local ..., to find out that /usr/local/bin/git-daemon starts /usr/sbin/git-upload-pack.
After creating a symlink to /usr/local/bin/git-upload-pack all works fine again, but I guess this is a mistake?
Cheers --- Jan
P.s. This is quite nasty to debug. I was forced to to run git-daemon stand-alone (not xinetd) another port and run strace -f -p <pid> to discover the cause of this problem. Even with --verbose, the only error response was the client complaining on unexpected EOF.