Re: [PATCH] Update, and clear up the pack format documentation a bit
- From
Shawn O. Pearce <spearce@spearce.org>
- Date
- Apr 6, 2008, 04:51 UTC
- Message-ID
- <20080406045132.GA10274@spearce.org>
- In-Reply-To
- <20080405180759.GA29710@bohr.gbar.dtu.dk>
Peter Eriksen <s022018@student.dtu.dk> wrote:
> The current documentation does not mention the ofs_delta pack > object type. This patch is also supposed to make the text a bit > more readable, since it moves the object entry header > description earlier.
...
Show 11 quoted lines
> diff --git a/Documentation/technical/pack-format.txt > b/Documentation/technical/pack-format.txt > index aa87756..35ee01d 100644 > --- a/Documentation/technical/pack-format.txt > +++ b/Documentation/technical/pack-format.txt > compressed delta data > + > + (for object type ofs_delta) > + n-byte offset (n*7-bit as above, but with size0 being 7 bit) > + compressed delta data > +
That is not correct. The ofs_delta is encoded as an n-byte offset that is subtracted from the current object's first byte (the byte holding the type/representation field and first 4 bits of length).
The n-byte encoding for an ofs_delta is different then the one used for the length. We add 1 for each byte where the MSB is 1. We also store the data in big-endian form (the most significant byte is first and the least significant byte is last).
See get_delta_base in sha1_file.c for the details of this.
In pack v4 I planned on using this particular encoding in more of the format than just here.
-- Shawn.