Re: [PATCH 0/2] merge --summary vs. merge.summary
- From
Jeff King <peff@peff.net>
- Date
- Apr 3, 2008, 10:30 UTC
- Message-ID
- <20080403103056.GD6673@coredump.intra.peff.net>
- In-Reply-To
- <1207213396-17370-1-git-send-email-szeder@ira.uka.de>
On Thu, Apr 03, 2008 at 11:03:14AM +0200, SZEDER Gábor wrote:
> So the '--summary' option controls the printing of diffstat, while the > 'merge.summary' config variable controls the behaviour of 'fmt-merge-msg',
Think that --diffstat is probably a better name. But your series actually _changes_ the meaning of --summary, which is probably a bad idea for people who have scripted around these.
The problem is that you have two concepts with the same name; giving one of the concepts the name means that the other concept breaks.
I think the most compatible way to go forward is to use two new names:
1. --summary (and --no- form) changes to --diffstat; --summary remains
as a compatibility alias for --diffstat. 2. merge.summary becomes merge.something_else, along with
--something-else support. merge.summary remains as a compatibility
option for merge.something_else.Though I can't think of a good "something_else". Given that there isn't even a command-line equivalent to merge.summary now, maybe just leave it as merge.summary, stop advertising --summary (even though it is a compatibility alias, we officially call it --diffstat), and then there is less confusion on the part of documentation readers (though perhaps more on the part of those who blindly try --summary).
-Peff