Re: [PATCH v4 00/34] Add directory rename detection to git
- From
Ramsay Jones <ramsay@ramsayjones.plus.com>
- Date
- Dec 13, 2017, 18:15 UTC
- Message-ID
- <14bf2760-2787-5dd3-e5cc-a2ec0e0d8950@ramsayjones.plus.com>
- In-Reply-To
- <xmqqh8svxwpm.fsf@gitster.mtv.corp.google.com>
On 13/12/17 01:06, Junio C Hamano wrote:
Show 20 quoted lines
> Elijah Newren <newren@gmail.com> writes: > >> This patchset introduces directory rename detection to merge-recursive. > > The use of negated form of test_i18ngrep in these patches are all > wrong. Because the helper must say "even though the string does not > match (does match), the test expects it to match (does not match), > and we know that expectation won't hold simply because we are under > poison build", so negating the result of test_i18ngrep won't work. > Instead, you would tell test_i18ngrep that we do not expect it to > find matching lines. > > Even with the attached, test #70 will still fail because you have a > construct that greps in output of test_i18ngrep. That won't work > under poison build, because the output of test_i18ngrep won't have > the string you are looking for under poison build. > > We may probably want to redirect the output of underlying grep to > /dev/null in test_i18ngrep to make this kind of misuse easier to > spot.
I have test-suite failures on the 'pu' branch for t4151-am-abort.sh (#3 and #6) and t5536-fetch-conflicts.sh (#3 and #6-7), which on a very quick inspection seem to be due to this (ie your SQUASH commit e5c5e24ad9).
For t4151 the test (both 3 & 6) is using test_i18ngrep on the output of a previous test_i18ngrep, and t5536 is doing likewise in the verify_stderr() helper function.
ATB, Ramsay Jones