git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 2/6 v5] revision.c: swap if/else blocks

From
Siddharth Kannan <kannan.siddharth12@gmail.com>
Date
Feb 25, 2017, 07:24 UTC
Message-ID
<1488007487-12965-3-git-send-email-kannan.siddharth12@gmail.com>
In-Reply-To
<1488007487-12965-1-git-send-email-kannan.siddharth12@gmail.com>

Swap the condition and bodies of an "if (A) do_A else do_B" in setup_revisions() to "if (!A) do_B else do A", to make the change in the the next step easier to read.

No behaviour change is intended in this step.
Signed-off-by: Siddharth Kannan <kannan.siddharth12@gmail.com>
---
 revision.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/revision.c b/revision.c
index 5674a9a..8d4ddae 100644
--- a/revision.c
+++ b/revision.c
@@ -2238,7 +2238,9 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s
 		}
 
 
-		if (handle_revision_arg(arg, revs, flags, revarg_opt)) {
+		if (!handle_revision_arg(arg, revs, flags, revarg_opt))
+			got_rev_arg = 1;
+		else {
 			int j;
 			if (seen_dashdash || *arg == '^')
 				die("bad revision '%s'", arg);
@@ -2255,8 +2257,6 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s
 			append_prune_data(&prune_data, argv + i);
 			break;
 		}
-		else
-			got_rev_arg = 1;
 	}
 
 	if (prune_data.nr) {
-- 
2.1.4
Previous: mashNext: Siddharth Kannan
Message 10 of 12 in “allow "-" as a shorthand for "previous branch"”
  1. 0/6 allow "-" as a shorthand for "previous branch"Siddharth Kannan, Feb 25, 2017
  2. 3/6 revision.c: args starting with "-" might be a revisionSiddharth Kannan, Feb 25, 2017
  3. 6/6 revert.c: delegate handling of "-" shorthand to setup_revisionsSiddharth Kannan, Feb 25, 2017
  4. Junio C HamanoMar 1, 2017
  5. 5/6 merge.c: delegate handling of "-" shorthand to revision.c:get_sha1Siddharth Kannan, Feb 25, 2017
  6. Junio C HamanoMar 1, 2017
  7. Junio C HamanoMar 1, 2017
  8. 4/6 sha1_name.c: teach get_sha1_1 "-" shorthand for "@{-1}"Siddharth Kannan, Feb 25, 2017
  9. 6/6 sha1_name.c: avoid parsing @{-1} unnecessarilymash, Mar 14, 2017
  10. 2/6 revision.c: swap if/else blocksSiddharth Kannan, Feb 25, 2017
  11. 1/6 revision.c: do not update argv with unknown optionSiddharth Kannan, Feb 25, 2017
  12. 1/6 revision.c: do not update argv with unknown optionSiddharth Kannan, Feb 25, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.