[PATCH 00/25] worktree lock, move, remove and unlock
- From
Nguyễn Thái Ngọc Duy <pclouds@gmail.com>
- Date
- Apr 13, 2016, 13:15 UTC
- Message-ID
- <1460553346-12985-1-git-send-email-pclouds@gmail.com>
This is basically a resend from last time, which happened during rc time. It adds 4 more commands, basically cleaning up the "TODO" list in git-worktree.txt.
So far I've only actually used move and remove (and maybe unlock once because worktree-add failed on me and I had to unlock it manually). And I don't get to move worktrees a lot either so not really extensive testing.
[01/25] usage.c: move format processing out of die_errno()
[02/25] usage.c: add sys_error() that prints strerror() automatically
[03/25] copy.c: import copy_file() from busybox
[04/25] copy.c: delete unused code in copy_file()
[05/25] copy.c: convert bb_(p)error_msg to (sys_)error
[06/25] copy.c: style fix
[07/25] copy.c: convert copy_file() to copy_dir_recursively()
[08/25] completion: support git-worktree
[09/25] git-worktree.txt: keep subcommand listing in alphabetical order
[10/25] path.c: add git_common_path() and strbuf_git_common_path()
[11/25] worktree.c: use is_dot_or_dotdot()
[12/25] worktree.c: store "id" instead of "git_dir"
[13/25] worktree.c: add clear_worktree()
[14/25] worktree.c: add find_worktree_by_path()
[15/25] worktree.c: add is_main_worktree()
[16/25] worktree.c: add validate_worktree()
[17/25] worktree.c: add update_worktree_location()
[18/25] worktree.c: add is_worktree_locked()
[19/25] worktree: avoid 0{40}, too many zeroes, hard to read
[20/25] worktree: simplify prefixing paths
[21/25] worktree: add "lock" command
[22/25] worktree: add "unlock" command
[23/25] worktree: add "move" commmand
[24/25] worktree move: accept destination as directory
[25/25] worktree: add "remove" commandTotal 11 files changed, 1028 insertions(+), 48 deletions(-)