git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 05/22] checkout: generalize die_if_checked_out() branch name argument

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Jul 17, 2015, 23:00 UTC
Message-ID
<1437174017-81687-6-git-send-email-sunshine@sunshineco.com>
In-Reply-To
<1437174017-81687-1-git-send-email-sunshine@sunshineco.com>

The plan is to publish die_if_checked_out() so that callers other than git-checkout can take advantage of it, however, those callers won't have access to git-checkout's "struct branch_info". Therefore, change it to accept the full name of the branch as a simple string instead.

While here, also give the argument a more meaningful name ("branch" instead of "new").

Signed-off-by: Eric Sunshine <sunshine@sunshineco.com>
---
No changes since v2.
 builtin/checkout.c | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/builtin/checkout.c b/builtin/checkout.c
index c36bf8a..177ad6a 100644
--- a/builtin/checkout.c
+++ b/builtin/checkout.c
@@ -873,7 +873,7 @@ static const char *unique_tracking_name(const char *name, unsigned char *sha1)
 	return NULL;
 }
 
-static void check_linked_checkout(struct branch_info *new, const char *id)
+static void check_linked_checkout(const char *branch, const char *id)
 {
 	struct strbuf sb = STRBUF_INIT;
 	struct strbuf path = STRBUF_INIT;
@@ -898,7 +898,7 @@ static void check_linked_checkout(struct branch_info *new, const char *id)
 	end = start;
 	while (*end && !isspace(*end))
 		end++;
-	if (strncmp(start, new->path, end - start) || new->path[end - start] != '\0')
+	if (strncmp(start, branch, end - start) || branch[end - start] != '\0')
 		goto done;
 	if (id) {
 		strbuf_reset(&path);
@@ -908,20 +908,21 @@ static void check_linked_checkout(struct branch_info *new, const char *id)
 		strbuf_rtrim(&gitdir);
 	} else
 		strbuf_addstr(&gitdir, get_git_common_dir());
-	die(_("'%s' is already checked out at '%s'"), new->name, gitdir.buf);
+	skip_prefix(branch, "refs/heads/", &branch);
+	die(_("'%s' is already checked out at '%s'"), branch, gitdir.buf);
 done:
 	strbuf_release(&path);
 	strbuf_release(&sb);
 	strbuf_release(&gitdir);
 }
 
-static void die_if_checked_out(struct branch_info *new)
+static void die_if_checked_out(const char *branch)
 {
 	struct strbuf path = STRBUF_INIT;
 	DIR *dir;
 	struct dirent *d;
 
-	check_linked_checkout(new, NULL);
+	check_linked_checkout(branch, NULL);
 
 	strbuf_addf(&path, "%s/worktrees", get_git_common_dir());
 	dir = opendir(path.buf);
@@ -932,7 +933,7 @@ static void die_if_checked_out(struct branch_info *new)
 	while ((d = readdir(dir)) != NULL) {
 		if (!strcmp(d->d_name, ".") || !strcmp(d->d_name, ".."))
 			continue;
-		check_linked_checkout(new, d->d_name);
+		check_linked_checkout(branch, d->d_name);
 	}
 	closedir(dir);
 }
@@ -1151,7 +1152,7 @@ static int checkout_branch(struct checkout_opts *opts,
 		char *head_ref = resolve_refdup("HEAD", 0, sha1, &flag);
 		if (head_ref &&
 		    (!(flag & REF_ISSYMREF) || strcmp(head_ref, new->path)))
-			die_if_checked_out(new);
+			die_if_checked_out(new->path);
 		free(head_ref);
 	}
 
-- 
2.5.0.rc2.378.g0af52e8
Previous: Eric SunshineNext: Eric Sunshine
Message 6 of 24 in “rid git-checkout of too-intimate knowledge of new worktree”
  1. 00/22 rid git-checkout of too-intimate knowledge of new worktreeEric Sunshine, Jul 17, 2015
  2. 01/22 checkout: avoid resolving HEAD unnecessarilyEric Sunshine, Jul 17, 2015
  3. 02/22 checkout: name check_linked_checkouts() more meaningfullyEric Sunshine, Jul 17, 2015
  4. 03/22 checkout: improve die_if_checked_out() robustnessEric Sunshine, Jul 17, 2015
  5. 04/22 checkout: die_if_checked_out: simplify strbuf managementEric Sunshine, Jul 17, 2015
  6. 05/22 checkout: generalize die_if_checked_out() branch name argumentEric Sunshine, Jul 17, 2015
  7. 06/22 checkout: check_linked_checkout: improve "already checked out" aestheticEric Sunshine, Jul 17, 2015
  8. 07/22 checkout: check_linked_checkout: simplify symref parsingEric Sunshine, Jul 17, 2015
  9. 08/22 checkout: teach check_linked_checkout() about symbolic link HEADEric Sunshine, Jul 17, 2015
  10. 09/22 branch: publish die_if_checked_out()Eric Sunshine, Jul 17, 2015
  11. 10/22 worktree: improve worktree setup messageEric Sunshine, Jul 17, 2015
  12. 11/22 worktree: simplify new branch (-b/-B) option checkingEric Sunshine, Jul 17, 2015
  13. 12/22 worktree: introduce options containerEric Sunshine, Jul 17, 2015
  14. 13/22 worktree: make --detach mutually exclusive with -b/-BEric Sunshine, Jul 17, 2015
  15. 14/22 worktree: add: suppress auto-vivication with --detach and no <branch>Eric Sunshine, Jul 17, 2015
  16. Eric SunshineJul 17, 2015
  17. 15/22 worktree: make branch creation distinct from worktree populationEric Sunshine, Jul 17, 2015
  18. 16/22 worktree: elucidate environment variables intended for child processesEric Sunshine, Jul 17, 2015
  19. 17/22 worktree: add_worktree: construct worktree-population command locallyEric Sunshine, Jul 17, 2015
  20. 18/22 worktree: detect branch-name/detached and error conditions locallyEric Sunshine, Jul 17, 2015
  21. 19/22 worktree: make setup of new HEAD distinct from worktree populationEric Sunshine, Jul 17, 2015
  22. 20/22 worktree: avoid resolving HEAD unnecessarilyEric Sunshine, Jul 17, 2015
  23. 21/22 worktree: populate via "git reset --hard" rather than "git checkout"Eric Sunshine, Jul 17, 2015
  24. 22/22 checkout: drop intimate knowledge of newly created worktreeEric Sunshine, Jul 17, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.