git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 02/20] checkout: name check_linked_checkouts() more meaningfully

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Jul 16, 2015, 08:20 UTC
Message-ID
<1437034825-32054-3-git-send-email-sunshine@sunshineco.com>
In-Reply-To
<1437034825-32054-1-git-send-email-sunshine@sunshineco.com>

check_linked_checkouts() doesn't just "check" linked checkouts for "something"; specifically, it aborts the operation if the branch about to be checked out is already checked out elsewhere. Therefore, rename it to die_if_checked_out() to give a better indication of its function. The more meaningful name will be particularly important when this function is later published for use by other callers.

Signed-off-by: Eric Sunshine <sunshine@sunshineco.com>
---
No changes since v1.
 builtin/checkout.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/builtin/checkout.c b/builtin/checkout.c
index 75f90a9..e75fb5e 100644
--- a/builtin/checkout.c
+++ b/builtin/checkout.c
@@ -910,7 +910,7 @@ done:
 	strbuf_release(&gitdir);
 }
 
-static void check_linked_checkouts(struct branch_info *new)
+static void die_if_checked_out(struct branch_info *new)
 {
 	struct strbuf path = STRBUF_INIT;
 	DIR *dir;
@@ -1152,7 +1152,7 @@ static int checkout_branch(struct checkout_opts *opts,
 		char *head_ref = resolve_refdup("HEAD", 0, sha1, &flag);
 		if (head_ref &&
 		    (!(flag & REF_ISSYMREF) || strcmp(head_ref, new->path)))
-			check_linked_checkouts(new);
+			die_if_checked_out(new);
 		free(head_ref);
 	}
 
-- 
2.5.0.rc2.378.g0af52e8
Previous: Eric SunshineNext: Eric Sunshine
Message 3 of 25 in “rid git-checkout of too-intimate knowledge of new worktree”
  1. 00/20 rid git-checkout of too-intimate knowledge of new worktreeEric Sunshine, Jul 16, 2015
  2. 01/20 checkout: avoid resolving HEAD unnecessarilyEric Sunshine, Jul 16, 2015
  3. 02/20 checkout: name check_linked_checkouts() more meaningfullyEric Sunshine, Jul 16, 2015
  4. 03/20 checkout: improve die_if_checked_out() robustnessEric Sunshine, Jul 16, 2015
  5. 04/20 checkout: die_if_checked_out: simplify strbuf managementEric Sunshine, Jul 16, 2015
  6. 05/20 checkout: generalize die_if_checked_out() branch name argumentEric Sunshine, Jul 16, 2015
  7. 06/20 checkout: check_linked_checkout: improve "already checked out" aestheticEric Sunshine, Jul 16, 2015
  8. Junio C HamanoJul 16, 2015
  9. Eric SunshineJul 17, 2015
  10. Duy NguyenJul 17, 2015
  11. 07/20 checkout: check_linked_checkout: simplify symref parsingEric Sunshine, Jul 16, 2015
  12. 08/20 checkout: teach check_linked_checkout() about symbolic link HEADEric Sunshine, Jul 16, 2015
  13. 09/20 branch: publish die_if_checked_out()Eric Sunshine, Jul 16, 2015
  14. 10/20 worktree: simplify new branch (-b/-B) option checkingEric Sunshine, Jul 16, 2015
  15. 11/20 worktree: introduce options containerEric Sunshine, Jul 16, 2015
  16. 12/20 worktree: make --detach mutually exclusive with -b/-BEric Sunshine, Jul 16, 2015
  17. 13/20 worktree: make branch creation distinct from worktree populationEric Sunshine, Jul 16, 2015
  18. 14/20 worktree: elucidate environment variables intended for child processesEric Sunshine, Jul 16, 2015
  19. 15/20 worktree: add_worktree: construct worktree-population command locallyEric Sunshine, Jul 16, 2015
  20. 16/20 worktree: detect branch-name/detached and error conditions locallyEric Sunshine, Jul 16, 2015
  21. 17/20 worktree: make setup of new HEAD distinct from worktree populationEric Sunshine, Jul 16, 2015
  22. 18/20 worktree: avoid resolving HEAD unnecessarilyEric Sunshine, Jul 16, 2015
  23. 19/20 worktree: populate via "git reset --hard" rather than "git checkout"Eric Sunshine, Jul 16, 2015
  24. 20/20 checkout: drop intimate knowledge of newly created worktreeEric Sunshine, Jul 16, 2015
  25. Junio C HamanoJul 16, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.