git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v8 02/11] for-each-ref: clean up code

From
Karthik Nayak <karthik.188@gmail.com>
Date
Jun 13, 2015, 19:37 UTC
Message-ID
<1434224249-21476-2-git-send-email-karthik.188@gmail.com>
In-Reply-To
<1434224249-21476-1-git-send-email-karthik.188@gmail.com>

In 'grab_single_ref()' remove the extra count variable 'cnt' and use the variable 'grab_cnt' of structure 'grab_ref_cbdata' directly instead.

Mentored-by: Christian Couder <christian.couder@gmail.com>
Mentored-by: Matthieu Moy <matthieu.moy@grenoble-inp.fr>
Signed-off-by: Karthik Nayak <karthik.188@gmail.com>
---
 builtin/for-each-ref.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/builtin/for-each-ref.c b/builtin/for-each-ref.c
index cc65620..f0d7d44 100644
--- a/builtin/for-each-ref.c
+++ b/builtin/for-each-ref.c
@@ -897,7 +897,6 @@ static int grab_single_ref(const char *refname, const struct object_id *oid,
 {
 	struct grab_ref_cbdata *cb = cb_data;
 	struct refinfo *ref;
-	int cnt;
 
 	if (flag & REF_BAD_NAME) {
 		  warning("ignoring ref with broken name %s", refname);
@@ -914,10 +913,8 @@ static int grab_single_ref(const char *refname, const struct object_id *oid,
 	 */
 	ref = new_refinfo(refname, oid->hash, flag);
 
-	cnt = cb->grab_cnt;
-	REALLOC_ARRAY(cb->grab_array, cnt + 1);
-	cb->grab_array[cnt++] = ref;
-	cb->grab_cnt = cnt;
+	REALLOC_ARRAY(cb->grab_array, cb->grab_cnt + 1);
+	cb->grab_array[cb->grab_cnt++] = ref;
 	return 0;
 }
 
-- 
2.4.3.435.g2403634.dirty
Previous: Karthik NayakNext: Karthik Nayak
Message 3 of 16 in “Create ref-filter from for-each-ref”
  1. 0/11 Create ref-filter from for-each-refkarthik nayak, Jun 13, 2015
  2. 01/11 for-each-ref: extract helper functions out of grab_single_ref()Karthik Nayak, Jun 13, 2015
  3. 02/11 for-each-ref: clean up codeKarthik Nayak, Jun 13, 2015
  4. 03/11 for-each-ref: rename 'refinfo' to 'ref_array_item'Karthik Nayak, Jun 13, 2015
  5. 04/11 for-each-ref: introduce new structures for better organisationKarthik Nayak, Jun 13, 2015
  6. 05/11 for-each-ref: introduce 'ref_array_clear()'Karthik Nayak, Jun 13, 2015
  7. 06/11 for-each-ref: rename some functions and make them publicKarthik Nayak, Jun 13, 2015
  8. 07/11 for-each-ref: rename variables called sort to sortingKarthik Nayak, Jun 13, 2015
  9. 08/11 ref-filter: add 'ref-filter.h'Karthik Nayak, Jun 13, 2015
  10. 09/11 ref-filter: move code from 'for-each-ref'Karthik Nayak, Jun 13, 2015
  11. 10/11 for-each-ref: introduce filter_refs()Karthik Nayak, Jun 13, 2015
  12. 11/11 ref-filter: make 'ref_array_item' use a FLEX_ARRAY for refnameKarthik Nayak, Jun 13, 2015
  13. Matthieu MoyJun 14, 2015
  14. karthik nayakJun 14, 2015
  15. Junio C HamanoJun 15, 2015
  16. karthik nayakJun 15, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.