Since v3:
- rename xmallocz_gentle to xmallocz_gently
- drop the unpack-objects patch
- fix allways type
Nguyễn Thái Ngọc Duy (5):
wrapper.c: introduce gentle xmallocz that does not die()
sha1_file.c: do not die failing to malloc in unpack_compressed_entry
diff.c: allow to pass more flags to diff_populate_filespec
diff --stat: mark any file larger than core.bigfilethreshold binary
diff: shortcut for diff'ing two binary SHA-1 objects
Documentation/config.txt | 3 +-
Documentation/gitattributes.txt | 4 +--
diff.c | 52 ++++++++++++++++++++++---------
diffcore-rename.c | 6 ++--
diffcore.h | 4 ++-
git-compat-util.h | 1 +
sha1_file.c | 4 ++-
t/t1050-large.sh | 20 ++++++++++++
wrapper.c | 68 +++++++++++++++++++++++++++++++----------
9 files changed, 125 insertions(+), 37 deletions(-)