[PATCH v3 0/1] general style: replaces memcmp() with starts_with()
- From
Quint Guvernator <quintus.public@gmail.com>
- Date
- Mar 15, 2014, 16:39 UTC
- Message-ID
- <1394901553-69548-1-git-send-email-quintus.public@gmail.com>
Hi, folks.
I've looked through the list's responses and removed the most objectionable hunks from the patch v2, especially in cases where starts_with either hurts readability or further obscures the use of magic numbers. Let me know what you all think about the changes.
Thank you all again for your help. This is my first patch here, and has been quite a microproject indeed!
Quint Guvernator (1): general style: replaces memcmp() with starts_with()
builtin/apply.c | 6 +++--- builtin/for-each-ref.c | 2 +- builtin/get-tar-commit-id.c | 2 +- builtin/mktag.c | 8 ++++---- builtin/patch-id.c | 18 +++++++++--------- commit.c | 4 ++-- connect.c | 6 +++--- contrib/convert-objects/convert-objects.c | 6 +++--- convert.c | 2 +- http-walker.c | 2 +- imap-send.c | 6 +++--- pack-write.c | 2 +- remote.c | 2 +- 13 files changed, 33 insertions(+), 33 deletions(-)
-- 1.9.0