git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH] install_branch_config(): switch from 'else-if' series to 'nested if-else'

From
NGNishhal Gaba <nishgaba9@gmail.com>
Date
Mar 12, 2014, 08:34 UTC
Message-ID
<1394613275-3327-1-git-send-email-nishgaba9@gmail.com>
From: Nishchal <nishgaba9@gmail.com>

I am Nishchal Gaba, a GSOC 2014 aspirant, submitting patch in response to microproject(8) Similar Execution Time, but increased readability

Alternate Solution Discarded: Table driven code using commonanilty of the statements to be printed due to _()
Signed-off-by: Nishchal Gaba <nishgaba9@gmail.com>
---
---
 branch.c | 28 +++++++++++++++++-----------
 1 file changed, 17 insertions(+), 11 deletions(-)
diff --git a/branch.c b/branch.c
index 723a36b..04e9e24 100644
--- a/branch.c
+++ b/branch.c
@@ -77,26 +77,32 @@ void install_branch_config(int flag, const char *local, const char *origin, cons
 	strbuf_release(&key);
 
 	if (flag & BRANCH_CONFIG_VERBOSE) {
-		if (remote_is_branch && origin)
-			printf_ln(rebasing ?
+		if (origin){
+			if(remote_is_branch)
+				printf_ln(rebasing ?
 				  _("Branch %s set up to track remote branch %s from %s by rebasing.") :
 				  _("Branch %s set up to track remote branch %s from %s."),
 				  local, shortname, origin);
-		else if (remote_is_branch && !origin)
-			printf_ln(rebasing ?
-				  _("Branch %s set up to track local branch %s by rebasing.") :
-				  _("Branch %s set up to track local branch %s."),
-				  local, shortname);
-		else if (!remote_is_branch && origin)
-			printf_ln(rebasing ?
+			else
+				printf_ln(rebasing ?
 				  _("Branch %s set up to track remote ref %s by rebasing.") :
 				  _("Branch %s set up to track remote ref %s."),
 				  local, remote);
-		else if (!remote_is_branch && !origin)
-			printf_ln(rebasing ?
+		}
+
+		else if (!origin){
+			if(remote_is_branch)
+				printf_ln(rebasing ?
+				  _("Branch %s set up to track local branch %s by rebasing.") :
+				  _("Branch %s set up to track local branch %s."),
+				  local, shortname);
+			else
+				printf_ln(rebasing ?
 				  _("Branch %s set up to track local ref %s by rebasing.") :
 				  _("Branch %s set up to track local ref %s."),
 				  local, remote);
+		}
+
 		else
 			die("BUG: impossible combination of %d and %p",
 			    remote_is_branch, origin);
-- 
1.8.1.2
Next: Matthieu Moy
Message 1 of 2 in “install_branch_config(): switch from 'else-if' series to 'nested if-else'”
  1. install_branch_config(): switch from 'else-if' series to 'nested if-else'Nishhal Gaba, Mar 12, 2014
  2. Matthieu MoyMar 12, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.