[PATCH v2 04/17] safe_create_leading_directories(): rename local variable
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- Jan 6, 2014, 13:45 UTC
- Message-ID
- <1389015935-21936-5-git-send-email-mhagger@alum.mit.edu>
- In-Reply-To
- <1389015935-21936-1-git-send-email-mhagger@alum.mit.edu>
Rename "pos" to "next_component", because now it always points at the next component of the path name that has to be processed.
Signed-off-by: Michael Haggerty <mhagger@alum.mit.edu> --- sha1_file.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/sha1_file.c b/sha1_file.c index 197766d..54202e8 100644 --- a/sha1_file.c +++ b/sha1_file.c @@ -107,18 +107,18 @@ int mkdir_in_gitdir(const char *path) int safe_create_leading_directories(char *path) { - char *pos = path + offset_1st_component(path); + char *next_component = path + offset_1st_component(path); - while (pos) { + while (next_component) { struct stat st; - char *slash = strchr(pos, '/'); + char *slash = strchr(next_component, '/'); if (!slash) break; while (*(slash + 1) == '/') slash++; - pos = slash + 1; - if (!*pos) + next_component = slash + 1; + if (!*next_component) break; *slash = '\0';
-- 1.8.5.2