[PATCH v2 1/2] submodule: fix confusing variable name
- From
brian m. carlson <sandals@crustytoothpaste.net>
- Date
- Aug 17, 2013, 17:25 UTC
- Message-ID
- <1376760343-741047-2-git-send-email-sandals@crustytoothpaste.net>
- In-Reply-To
- <1376760343-741047-1-git-send-email-sandals@crustytoothpaste.net>
cmd_summary reads the output of git diff, but reads in the submodule path into a variable called name. Since this variable does not contain the name of the submodule, but the path, rename it to be clearer what data it actually holds.
Signed-off-by: brian m. carlson <sandals@crustytoothpaste.net> --- git-submodule.sh | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/git-submodule.sh b/git-submodule.sh index 2979197..38520db 100755 --- a/git-submodule.sh +++ b/git-submodule.sh @@ -1032,13 +1032,13 @@ cmd_summary() { # Get modified modules cared by user modules=$(git $diff_cmd $cached --ignore-submodules=dirty --raw $head -- "$@" | sane_egrep '^:([0-7]* )?160000' | - while read mod_src mod_dst sha1_src sha1_dst status name + while read mod_src mod_dst sha1_src sha1_dst status sm_path do # Always show modules deleted or type-changed (blob<->module) - test $status = D -o $status = T && echo "$name" && continue + test $status = D -o $status = T && echo "$sm_path" && continue # Also show added or modified modules which are checked out - GIT_DIR="$name/.git" git-rev-parse --git-dir >/dev/null 2>&1 && - echo "$name" + GIT_DIR="$sm_path/.git" git-rev-parse --git-dir >/dev/null 2>&1 && + echo "$sm_path" done )
-- 1.8.4.rc2.564.g10ce5ae