git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 0/9] Extending the shelf-life of "git describe" output

From
Junio C Hamano <gitster@pobox.com>
Date
Jun 21, 2012, 06:35 UTC
Message-ID
<1340260532-11378-1-git-send-email-gitster@pobox.com>
This is take 2.  The first round was $gmane/200165.

A major difference from v1 is the [PATCH 6/9]. The earlier approach was to filter out candidates that match the given prefix for additional criteria as they are found in the loop, but this round tries to optimize for the common case of not having ambiguities. We postpone running additional test until we find the second object that match the prefix (in other words, if there is only one object that has the prefix, we do not apply the "we know this name refers to a commit" hint, and let the caller deal with a non commit object, just like the current code does).

Junio C Hamano (9):
  sha1_name.c: indentation fix
  sha1_name.c: clarify what "fake" is for in find_short_object_filename()
  sha1_name.c: rename "now" to "current"
  sha1_name.c: refactor find_short_packed_object()
  sha1_name.c: correct misnamed "canonical" and "res"
  sha1_name.c: restructure disambiguation of short names
  sha1_name.c: allow get_short_sha1() to take other flags
  sha1_name.c: teach get_short_sha1() a commit-only option
  sha1_name.c: get_describe_name() by definition groks only commits
 sha1_name.c | 282 +++++++++++++++++++++++++++++++++++++++---------------------
 1 file changed, 182 insertions(+), 100 deletions(-)
-- 
1.7.11.2.gd284367
Next: Junio C Hamano
Message 1 of 12 in “Extending the shelf-life of "git describe" output”
  1. 0/9 Extending the shelf-life of "git describe" outputJunio C Hamano, Jun 21, 2012
  2. 1/9 sha1_name.c: indentation fixJunio C Hamano, Jun 21, 2012
  3. 2/9 sha1_name.c: clarify what "fake" is for in find_short_object_filename()Junio C Hamano, Jun 21, 2012
  4. 3/9 sha1_name.c: rename "now" to "current"Junio C Hamano, Jun 21, 2012
  5. 4/9 sha1_name.c: refactor find_short_packed_object()Junio C Hamano, Jun 21, 2012
  6. 5/9 sha1_name.c: correct misnamed "canonical" and "res"Junio C Hamano, Jun 21, 2012
  7. 6/9 sha1_name.c: restructure disambiguation of short namesJunio C Hamano, Jun 21, 2012
  8. 7/9 sha1_name.c: allow get_short_sha1() to take other flagsJunio C Hamano, Jun 21, 2012
  9. 8/9 sha1_name.c: teach get_short_sha1() a commit-only optionJunio C Hamano, Jun 21, 2012
  10. 9/9 sha1_name.c: get_describe_name() by definition groks only commitsJunio C Hamano, Jun 21, 2012
  11. Erik Faye-LundJun 21, 2012
  12. Junio C HamanoJun 21, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.