Hi,
There are 10 parts in this iteration. The main changes are:
- "t3502, t3510: clarify cherry-pick -m failure" and "revert: move
replay_action, replay_subcommand to header" are new. They've been
made separate parts for clarity.
- Since jn/maint-sequencer-fixes contains "revert: pass around
rev-list args in already-parsed form", I've dropped it from this
series. Except for the tests, I've checked that it doesn't conflict
with the topic.
- Rebased on new `master`.
- Other changes are fairly minor, and mainly arise as responses to
Jonathan's reviews.
Thanks.
-- Ram
Ramkumar Ramachandra (10):
revert: free msg in format_todo()
revert: make commit subjects in insn sheet optional
revert: tolerate extra spaces, tabs in insn sheet
revert: simplify getting commit subject in format_todo()
t3510 (cherry-pick-sequencer): use exit status
t3502, t3510: clarify cherry-pick -m failure
t3510 (cherry-pick-sequencer): remove malformed sheet 2
revert: move replay_action, replay_subcommand to header
revert: allow mixed pick and revert instructions
revert: report fine-grained error messages from insn parser
builtin/revert.c | 194 ++++++++++++++++++++-------------------
sequencer.h | 18 ++++
t/t3502-cherry-pick-merge.sh | 2 +-
t/t3510-cherry-pick-sequence.sh | 142 +++++++++++++++++++++++------
4 files changed, 231 insertions(+), 125 deletions(-)