git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 02/11] object.c: remove duplicated code for object hashing

From
Junio C Hamano <gitster@pobox.com>
Date
Aug 11, 2011, 17:53 UTC
Message-ID
<1313085196-13249-3-git-send-email-gitster@pobox.com>
In-Reply-To
<1313085196-13249-1-git-send-email-gitster@pobox.com>

The index into object hash was computed in two different places, risking them to diverge. Implement a single helper function and use it in these two locations.

Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 object.c |   17 +++++------------
 1 files changed, 5 insertions(+), 12 deletions(-)
diff --git a/object.c b/object.c
index 35ff130..4ff2d7d 100644
--- a/object.c
+++ b/object.c
@@ -43,23 +43,16 @@ struct object *get_indexed_object(unsigned int idx)
 	return obj_hash[idx];
 }
 
-static unsigned int hash_obj(struct object *obj, unsigned int n)
+static unsigned int hash_val(const unsigned char *sha1)
 {
 	unsigned int hash;
-	memcpy(&hash, obj->sha1, sizeof(unsigned int));
-	return hash % n;
-}
-
-static unsigned int hashtable_index(const unsigned char *sha1)
-{
-	unsigned int i;
-	memcpy(&i, sha1, sizeof(unsigned int));
-	return i % obj_hash_size;
+	memcpy(&hash, sha1, sizeof(unsigned int));
+	return hash;
 }
 
 static void insert_obj_hash(struct object *obj, struct object **hash, unsigned int size)
 {
-	unsigned int j = hash_obj(obj, size);
+	unsigned int j = hash_val(obj->sha1) % size;
 
 	while (hash[j]) {
 		j++;
@@ -77,7 +70,7 @@ struct object *lookup_object(const unsigned char *sha1)
 	if (!obj_hash)
 		return NULL;
 
-	i = hashtable_index(sha1);
+	i = hash_val(sha1) % obj_hash_size;
 	while ((obj = obj_hash[i]) != NULL) {
 		if (!hashcmp(sha1, obj->sha1))
 			break;
-- 
1.7.6.433.g1421f
Previous: Junio C HamanoNext: Junio C Hamano
Message 3 of 15 in “Micro-optimizing lookup_object()”
  1. 00/11 Micro-optimizing lookup_object()Junio C Hamano, Aug 11, 2011
  2. 01/11 object.c: code movement for readabilityJunio C Hamano, Aug 11, 2011
  3. 02/11 object.c: remove duplicated code for object hashingJunio C Hamano, Aug 11, 2011
  4. 03/11 pack-objects --count-onlyJunio C Hamano, Aug 11, 2011
  5. 04/11 object: next_size() helper for readabilityJunio C Hamano, Aug 11, 2011
  6. 05/11 object hash: we know the table size is a power of twoJunio C Hamano, Aug 11, 2011
  7. 06/11 object: growing the hash-table more aggressively does not help muchJunio C Hamano, Aug 11, 2011
  8. 07/11 object: try naive cuckoo hashingJunio C Hamano, Aug 11, 2011
  9. 08/11 object: try 5-way cuckoo -- use all 20-bytes of SHA-1Junio C Hamano, Aug 11, 2011
  10. 09/11 object: try 4-way cuckooJunio C Hamano, Aug 11, 2011
  11. 10/11 object: try 3-way cuckooJunio C Hamano, Aug 11, 2011
  12. 11/11 object: try 2-way cuckoo againJunio C Hamano, Aug 11, 2011
  13. 12/11 object.c: make object hash implementation more opaqueJunio C Hamano, Aug 11, 2011
  14. git_checkattr() is inefficient when repeated [Re: [PATCH 00/11] Micro-optimizing lookup_object()]Thomas Rast, Aug 12, 2011
  15. Junio C HamanoAug 15, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.