Re: [PATCH 1/4] test-svn-fe: split off "test-svn-fe -d" into a separate function
- From
Drew Northup <drew.northup@maine.edu>
- Date
- May 31, 2011, 16:18 UTC
- Message-ID
- <1306858704.13283.2.camel@drew-northup.unet.maine.edu>
- In-Reply-To
- <20110527110914.GB7972@elie>
On Fri, 2011-05-27 at 06:09 -0500, Jonathan Nieder wrote:
Show 6 quoted lines
> The helper for testing the svndiff library is getting dangerously > close to the right margin. Split it off into a separate function so > it is easier to contemplate on its own. > > In other words, this just unindents the code a little. No functional > change intended.
> > +static const char test_svnfe_usage[] = > + "test-svn-fe (<dumpfile> | [-d] <preimage> <delta> <len>)";
> int main(int argc, char *argv[])
> {
> - static const char test_svnfe_usage[] =
> - "test-svn-fe (<dumpfile> | [-d] <preimage> <delta> <len>)";How is this germane to the original intent? Is there a gain by making it global (to that file) that I'm missing?
-- -Drew Northup ________________________________________________ "As opposed to vegetable or mineral error?" -John Pescatore, SANS NewsBites Vol. 12 Num. 59