git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 3/3] Use the new {real,absolute}_path function names

From
Carlos Martín Nieto <cmn@elego.de>
Date
Mar 16, 2011, 16:37 UTC
Message-ID
<1300293451.7214.47.camel@bee.lab.cmartin.tk>
In-Reply-To
<AANLkTikvb0-XJKwNmaJGeJiZQzYC=_k9_MChyOgvkE1o@mail.gmail.com>
On mié, 2011-03-16 at 17:24 +0100, Erik Faye-Lund wrote:
Show 7 quoted lines
> On Wed, Mar 16, 2011 at 5:06 PM, Carlos Martín Nieto <cmn@elego.de> wrote:
> > Use the new names for path functions in the code. Replace uses of
> > make_absolute_path with real_path, make_nonrelative_path with
> > absolute_path and make_relative_path with relative_path.
> 
> Shouldn't these changes be squashed into the previous two commits so
> it'll be possible to bisect across it without getting a broken build?
 Brian pointed this out in the other subthread. I'll resend.
Previous: Erik Faye-LundNext: Carlos Martín Nieto
Message 9 of 10 in “Rename make_*_path with clearer names”
  1. 0/3 Rename make_*_path with clearer namesCarlos Martín Nieto, Mar 16, 2011
  2. 1/3 make_absolute_path: return the input path if it points to our bufferCarlos Martín Nieto, Mar 16, 2011
  3. Junio C HamanoMar 16, 2011
  4. 2/3 Name make_*_path functions more accuratelyCarlos Martín Nieto, Mar 16, 2011
  5. Brian GernhardtMar 16, 2011
  6. Carlos Martín NietoMar 16, 2011
  7. 3/3 Use the new {real,absolute}_path function namesCarlos Martín Nieto, Mar 16, 2011
  8. Erik Faye-LundMar 16, 2011
  9. Carlos Martín NietoMar 16, 2011
  10. 3/3 Name make_*_path functions more accuratelyCarlos Martín Nieto, Mar 16, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.