git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 4/5] rebase: remove unused rebase state 'prev_head'

From
martin.von.zweigbergk@gmail.com <martin.von.zweigbergk@gmail.com>
Date
Nov 3, 2010, 21:09 UTC
Message-ID
<1288818580-7576-5-git-send-email-martin.von.zweigbergk@gmail.com>
In-Reply-To
<1288818580-7576-1-git-send-email-martin.von.zweigbergk@gmail.com>
From: Martin von Zweigbergk <martin.von.zweigbergk@gmail.com>
The rebase state 'prev_head' is not used. Remove it.
Signed-off-by: Martin von Zweigbergk <martin.von.zweigbergk@gmail.com>
---
 git-rebase.sh |    8 --------
 1 files changed, 0 insertions(+), 8 deletions(-)
diff --git a/git-rebase.sh b/git-rebase.sh
index 2c812b2..a7428ea 100755
--- a/git-rebase.sh
+++ b/git-rebase.sh
@@ -60,7 +60,6 @@ read_state () {
 	if test -d "$merge_dir"
 	then
 		state_dir="$merge_dir"
-		prev_head=$(cat "$merge_dir"/prev_head) &&
 		onto_name=$(cat "$merge_dir"/onto_name) &&
 		end=$(cat "$merge_dir"/end) &&
 		msgnum=$(cat "$merge_dir"/msgnum)
@@ -74,7 +73,6 @@ read_state () {
 }
 
 continue_merge () {
-	test -n "$prev_head" || die "prev_head must be defined"
 	test -d "$merge_dir" || die "$merge_dir directory does not exist"
 
 	unmerged=$(git ls-files -u)
@@ -108,10 +106,6 @@ continue_merge () {
 	test -z "$GIT_QUIET" &&
 	GIT_PAGER='' git log --format=%s -1 "$cmt"
 
-	prev_head=`git rev-parse HEAD^0`
-	# save the resulting commit so we can read-tree on it later
-	echo "$prev_head" > "$merge_dir/prev_head"
-
 	# onto the next patch:
 	msgnum=$(($msgnum + 1))
 	echo "$msgnum" >"$merge_dir/msgnum"
@@ -574,8 +568,6 @@ fi
 
 mkdir -p "$merge_dir"
 echo "$onto_name" > "$merge_dir/onto_name"
-prev_head=$orig_head
-echo "$prev_head" > "$merge_dir/prev_head"
 echo "$head_name" > "$merge_dir/head-name"
 echo "$onto" > "$merge_dir/onto"
 echo "$orig_head" > "$merge_dir/orig-head"
-- 
1.7.3.rc1.4.g5879b6
Previous: martin.von.zweigbergk@gmail.comNext: martin.von.zweigbergk@gmail.com
Message 5 of 6 in “Make git-rebase.sh more readable and easier to extend”
  1. 0/5 Make git-rebase.sh more readable and easier to extendmartin.von.zweigbergk@gmail.com, Nov 3, 2010
  2. 1/5 rebase: clearer names for directory variablesmartin.von.zweigbergk@gmail.com, Nov 3, 2010
  3. 2/5 rebase: refactor reading of statemartin.von.zweigbergk@gmail.com, Nov 3, 2010
  4. 3/5 rebase: read state outside loopmartin.von.zweigbergk@gmail.com, Nov 3, 2010
  5. 4/5 rebase: remove unused rebase state 'prev_head'martin.von.zweigbergk@gmail.com, Nov 3, 2010
  6. 5/5 rebase: read state explicitly in '--abort'martin.von.zweigbergk@gmail.com, Nov 3, 2010

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.