Hi,
Here is the 2nd iteration of my refactoring patches.
Michael Lukashov (4):
Refactoring: remove duplicated code from builtin-send-pack.c and
transport.c
Refactoring: connect.c: move duplicated code to get_host_and_port
Refactoring: move duplicated code from builtin-pack-objects.c and
fast-import.c to object.c
Refactoring: remove duplicated code from builtin-checkout.c and
merge-recursive.c builtin-checkout.c | 18 -----
builtin-fetch.c | 20 +++---
builtin-pack-objects.c | 27 -------
builtin-send-pack.c | 190 +----------------------------------------------
connect.c | 83 +++++++--------------
fast-import.c | 23 ------
merge-recursive.c | 2 +-
merge-recursive.h | 3 +
object.c | 20 +++++
object.h | 9 ++
transport.c | 27 +++----
transport.h | 11 +++
12 files changed, 101 insertions(+), 332 deletions(-)