[EGIT PATCH v5 0/7] Ref rename support again
- From
Robin Rosenberg <robin.rosenberg@dewire.com>
- Date
- Jun 10, 2009, 21:22 UTC
- Message-ID
- <1244668945-12622-1-git-send-email-robin.rosenberg@dewire.com>
- In-Reply-To
- <1241652781-16873-1-git-send-email-robin.rosenberg@dewire.com>
More tests, leading to fixes of minor bugs, plus corrections according to Shawn's comments.
-- robin
Robin Rosenberg (6):
Add methods to RawParseUtils for scanning backwards.
Add a ref log reader class
Add ref rename support to JGit
Add ref rename support to the branch dialog
Improve error reporting in the branch dialog
Remove a TAB from the message Egit generates into the reflog on
commitShawn O. Pearce (1): Do not write to the reflog unless the refupdate logmessage is set
.../src/org/spearce/egit/ui/UIText.java | 18 + .../egit/ui/internal/actions/CommitAction.java | 2 +- .../ui/internal/dialogs/BranchSelectionDialog.java | 133 ++++++-- .../src/org/spearce/egit/ui/uitext.properties | 7 + .../org/spearce/jgit/test/resources/packed-refs | 1 + .../tst/org/spearce/jgit/lib/RefUpdateTest.java | 348 +++++++++++++++++++- .../tst/org/spearce/jgit/lib/ReflogReaderTest.java | 166 ++++++++++ .../org/spearce/jgit/lib/RepositoryTestCase.java | 18 + .../org/spearce/jgit/transport/TransportTest.java | 2 +- .../src/org/spearce/jgit/lib/RefDatabase.java | 31 ++ .../src/org/spearce/jgit/lib/RefLogWriter.java | 33 ++- .../src/org/spearce/jgit/lib/RefRename.java | 163 +++++++++ .../src/org/spearce/jgit/lib/RefUpdate.java | 115 +++++-- .../src/org/spearce/jgit/lib/ReflogReader.java | 187 +++++++++++ .../src/org/spearce/jgit/lib/Repository.java | 30 ++ .../src/org/spearce/jgit/util/RawParseUtils.java | 84 +++++- 16 files changed, 1269 insertions(+), 69 deletions(-) create mode 100644 org.spearce.jgit.test/tst/org/spearce/jgit/lib/ReflogReaderTest.java create mode 100644 org.spearce.jgit/src/org/spearce/jgit/lib/RefRename.java create mode 100644 org.spearce.jgit/src/org/spearce/jgit/lib/ReflogReader.java
Short log of my patch queue before rebase:
Mine
Add methods to RawParseUtils for scanning backwards.
Add a ref log reader class
Do not write to the reflog unless the refupdate logmessage is set
Revert "Do not write to the reflog unless the refupdate logmessage is set"
Add ref rename support to JGit
Add ref rename support to the branch dialog
Improve error reporting in the branch dialog
Shawns comments, except the no-reflog update
Remove a TAB from the message Egit generated into the reflog on commit
Follow C Git's format for renames in the reflog
Improve refupdate comment
..ReflogReader
Move reflog creation to testcase base class
..rename testsShawn:
Do not write to the reflog unless the refupdate logmessage is set