git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH] Move read_cache_unmerged() to read-cache.c

From
Miklos Vajna <vmiklos@frugalware.org>
Date
Jun 7, 2008, 01:00 UTC
Message-ID
<1212800445-4365-1-git-send-email-vmiklos@frugalware.org>
In-Reply-To
<7vhcc7zdm5.fsf@gitster.siamese.dyndns.org>

builtin-read-tree has a read_cache_unmerged() which is useful for other builtins, for example builtin-merge uses it as well. Move it to read-cache.c to avoid code duplication.

Signed-off-by: Miklos Vajna <vmiklos@frugalware.org>
---
On Thu, Jun 05, 2008 at 04:05:54PM -0700, Junio C Hamano <gitster@pobox.com> wrote:
Show 12 quoted lines
> Looks good, but as a public interface probably it needs a few lines of
> comment in front of the function's definition to describe what it is
> used
> for.  Perhaps like...
>
> /*
>  * Read the index file that is potentially unmerged into given
>  * index_state, dropping any unmerged entries.  Returns true is
>  * the index is unmerged.  Callers who want to refuse to work
>  * from an unmerged state can call this and check its return value,
>  * instead of calling read_cache().
>  */
Added. I'm sending the patch I just pushed to my working branch.
 builtin-read-tree.c |   24 ------------------------
 cache.h             |    2 ++
 read-cache.c        |   31 +++++++++++++++++++++++++++++++
 3 files changed, 33 insertions(+), 24 deletions(-)
diff --git a/builtin-read-tree.c b/builtin-read-tree.c
index 5a09e17..72a6de3 100644
--- a/builtin-read-tree.c
+++ b/builtin-read-tree.c
@@ -29,30 +29,6 @@ static int list_tree(unsigned char *sha1)
 	return 0;
 }
 
-static int read_cache_unmerged(void)
-{
-	int i;
-	struct cache_entry **dst;
-	struct cache_entry *last = NULL;
-
-	read_cache();
-	dst = active_cache;
-	for (i = 0; i < active_nr; i++) {
-		struct cache_entry *ce = active_cache[i];
-		if (ce_stage(ce)) {
-			remove_name_hash(ce);
-			if (last && !strcmp(ce->name, last->name))
-				continue;
-			cache_tree_invalidate_path(active_cache_tree, ce->name);
-			last = ce;
-			continue;
-		}
-		*dst++ = ce;
-	}
-	active_nr = dst - active_cache;
-	return !!last;
-}
-
 static void prime_cache_tree_rec(struct cache_tree *it, struct tree *tree)
 {
 	struct tree_desc desc;
diff --git a/cache.h b/cache.h
index e342ad3..df0ac56 100644
--- a/cache.h
+++ b/cache.h
@@ -254,6 +254,7 @@ static inline void remove_name_hash(struct cache_entry *ce)
 
 #define read_cache() read_index(&the_index)
 #define read_cache_from(path) read_index_from(&the_index, (path))
+#define read_cache_unmerged() read_index_unmerged(&the_index)
 #define write_cache(newfd, cache, entries) write_index(&the_index, (newfd))
 #define discard_cache() discard_index(&the_index)
 #define unmerged_cache() unmerged_index(&the_index)
@@ -357,6 +358,7 @@ extern int init_db(const char *template_dir, unsigned int flags);
 /* Initialize and use the cache information */
 extern int read_index(struct index_state *);
 extern int read_index_from(struct index_state *, const char *path);
+extern int read_index_unmerged(struct index_state *);
 extern int write_index(const struct index_state *, int newfd);
 extern int discard_index(struct index_state *);
 extern int unmerged_index(const struct index_state *);
diff --git a/read-cache.c b/read-cache.c
index 8e5fbb6..ea23726 100644
--- a/read-cache.c
+++ b/read-cache.c
@@ -1394,3 +1394,34 @@ int write_index(const struct index_state *istate, int newfd)
 	}
 	return ce_flush(&c, newfd);
 }
+
+/*
+ * Read the index file that is potentially unmerged into given
+ * index_state, dropping any unmerged entries.  Returns true is
+ * the index is unmerged.  Callers who want to refuse to work
+ * from an unmerged state can call this and check its return value,
+ * instead of calling read_cache().
+ */
+int read_index_unmerged(struct index_state *istate)
+{
+	int i;
+	struct cache_entry **dst;
+	struct cache_entry *last = NULL;
+
+	read_index(istate);
+	dst = istate->cache;
+	for (i = 0; i < istate->cache_nr; i++) {
+		struct cache_entry *ce = istate->cache[i];
+		if (ce_stage(ce)) {
+			remove_name_hash(ce);
+			if (last && !strcmp(ce->name, last->name))
+				continue;
+			cache_tree_invalidate_path(istate->cache_tree, ce->name);
+			last = ce;
+			continue;
+		}
+		*dst++ = ce;
+	}
+	istate->cache_nr = dst - istate->cache;
+	return !!last;
+}
-- 
1.5.6.rc0.dirty
Previous: Junio C HamanoNext: Junio C Hamano
Message 41 of 45 in “Build in merge”
  1. 00/10 Build in mergeMiklos Vajna, Jun 5, 2008
  2. 01/10 Move split_cmdline() to alias.cMiklos Vajna, Jun 5, 2008
  3. 02/10 Move commit_list_count() to commit.cMiklos Vajna, Jun 5, 2008
  4. 03/10 Move builtin-remote's skip_prefix() to git-compat-util.hMiklos Vajna, Jun 5, 2008
  5. 04/10 Add new test to ensure git-merge handles pull.twohead and pull.octopusMiklos Vajna, Jun 5, 2008
  6. 05/10 parseopt: add a new PARSE_OPT_ARGV0_IS_AN_OPTION optionMiklos Vajna, Jun 5, 2008
  7. 06/10 Move read_cache_unmerged() to read-cache.cMiklos Vajna, Jun 5, 2008
  8. 07/10 git-fmt-merge-msg: make it useable from other builtinsMiklos Vajna, Jun 5, 2008
  9. 08/10 Introduce commit_list_append() in commit.cMiklos Vajna, Jun 5, 2008
  10. 09/10 Introduce get_octopus_merge_bases() in commit.cMiklos Vajna, Jun 5, 2008
  11. 10/10 Build in mergeMiklos Vajna, Jun 5, 2008
  12. Junio C HamanoJun 6, 2008
  13. Junio C HamanoJun 6, 2008
  14. Johannes SchindelinJun 6, 2008
  15. Johannes SchindelinJun 6, 2008
  16. Junio C HamanoJun 6, 2008
  17. Introduce get_octopus_merge_bases() in commit.cMiklos Vajna, Jun 7, 2008
  18. Johannes SchindelinJun 9, 2008
  19. Introduce get_octopus_merge_bases() in commit.cMiklos Vajna, Jun 9, 2008
  20. Junio C HamanoJun 9, 2008
  21. Johannes SchindelinJun 9, 2008
  22. Junio C HamanoJun 9, 2008
  23. Miklos VajnaJun 9, 2008
  24. Junio C HamanoJun 9, 2008
  25. Miklos VajnaJun 9, 2008
  26. Johannes SchindelinJun 9, 2008
  27. Junio C HamanoJun 9, 2008
  28. Miklos VajnaJun 10, 2008
  29. Johannes SchindelinJun 10, 2008
  30. Johannes SchindelinJun 6, 2008
  31. Miklos VajnaJun 7, 2008
  32. Junio C HamanoJun 5, 2008
  33. Miklos VajnaJun 6, 2008
  34. Junio C HamanoJun 7, 2008
  35. Miklos VajnaJun 7, 2008
  36. Junio C HamanoJun 5, 2008
  37. Miklos VajnaJun 7, 2008
  38. Andreas EricssonJun 9, 2008
  39. git-fmt-merge-msg: make it usable from other builtinsMiklos Vajna, Jun 9, 2008
  40. Junio C HamanoJun 5, 2008
  41. Move read_cache_unmerged() to read-cache.cMiklos Vajna, Jun 7, 2008
  42. Junio C HamanoJun 5, 2008
  43. Add new test to ensure git-merge handles pull.twohead and pull.octopusMiklos Vajna, Jun 7, 2008
  44. Junio C HamanoJun 5, 2008
  45. Move parse-options's skip_prefix() to git-compat-util.hMiklos Vajna, Jun 6, 2008

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.