[PATCH] pack-bitmap-write: use hashwrite_be32() in write_hash_cache()
- From
René Scharfe <l.s.r@web.de>
- Date
- Sep 6, 2020, 08:59 UTC
- Message-ID
- <1143b9e0-3adf-095f-78cf-2f8d8c2bd368@web.de>
Call hashwrite_be32() instead of open-coding it. This is shorter and easier to read.
Signed-off-by: René Scharfe <l.s.r@web.de> --- pack-bitmap-write.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/pack-bitmap-write.c b/pack-bitmap-write.c index a7a4964b50..5e998bdaa7 100644 --- a/pack-bitmap-write.c +++ b/pack-bitmap-write.c @@ -503,8 +503,7 @@ static void write_hash_cache(struct hashfile *f, for (i = 0; i < index_nr; ++i) { struct object_entry *entry = (struct object_entry *)index[i]; - uint32_t hash_value = htonl(entry->hash); - hashwrite(f, &hash_value, sizeof(hash_value)); + hashwrite_be32(f, entry->hash); } } -- 2.28.0