git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH] shell: use skip_prefix() instead of starts_with()

From
René Scharfe <l.s.r@web.de>
Date
Nov 26, 2019, 15:00 UTC
Message-ID
<0a4dfbcc-9eb5-6b39-6b93-0014f5c475de@web.de>

Get rid of a magic number by using skip_prefix() instead of starts_with().

Signed-off-by: René Scharfe <l.s.r@web.de>
---
 shell.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/shell.c b/shell.c
index 40084a3013..54cca7439d 100644
--- a/shell.c
+++ b/shell.c
@@ -16,10 +16,10 @@ static int do_generic_cmd(const char *me, char *arg)
 	setup_path();
 	if (!arg || !(arg = sq_dequote(arg)) || *arg == '-')
 		die("bad argument");
-	if (!starts_with(me, "git-"))
+	if (!skip_prefix(me, "git-", &me))
 		die("bad command");

-	my_argv[0] = me + 4;
+	my_argv[0] = me;
 	my_argv[1] = arg;
 	my_argv[2] = NULL;

--
2.24.0
Next: Jeff King
Message 1 of 3 in “shell: use skip_prefix() instead of starts_with()”
  1. shell: use skip_prefix() instead of starts_with()René Scharfe, Nov 26, 2019
  2. Jeff KingNov 26, 2019
  3. René ScharfeNov 26, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.