git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 2/2] diff.c: More changes and tests around utf8_strwidth()

From
Johannes Schindelin <johannes.schindelin@gmx.de>
Date
Sep 2, 2022, 10:12 UTC
Message-ID
<00059orr-6p52-q0ro-306r-s225561s2912@tzk.qr>
In-Reply-To
<20220902042138.13901-1-tboegi@web.de>
Hi Torsten,
On Fri, 2 Sep 2022, tboegi@web.de wrote:
Show 11 quoted lines
> diff --git a/diff.c b/diff.c
> index b5df464de5..cf38e1dc88 100644
> --- a/diff.c
> +++ b/diff.c
> [...]
> @@ -2753,10 +2754,14 @@ static void show_stats(struct diffstat_t *data, struct diff_options *options)
>  			if (slash)
>  				name = slash;
>  		}
> +		if (len > utf8_strwidth(name))
> +			num_padding_spaces = len - utf8_strwidth(name);

Here, we determine how many spaces are needed for padding. The value is later used in three instances, and from the diff it is not immediately obvious that all code paths are covered. I did verify locally that this is the case, though, so all is good.

>
>  		if (file->is_binary) {
> -			strbuf_addf(&out, " %s%-*s |", prefix, len, name);
> -			strbuf_addf(&out, " %*s", number_width, "Bin");

This was already a bit wasteful by calling `strbuf_addf()` twice, where one time would have sufficed. (This applies to the other two code paths below, too.)

> +			strbuf_addf(&out, " %s%s ", prefix,  name);
> +			if (num_padding_spaces)
> +				strbuf_addchars(&out, ' ', num_padding_spaces);
> +			strbuf_addf(&out, "| %*s", number_width, "Bin");
Instead of fixing this, we now add yet another `strbuf*()` call.
But this could be done more elegantly, via a single `strbuf_addf()` call:
			strbuf_addf(&out, "%s%s%*s | %*s",
				    prefix, name, num_padding_spaces, "",
				    number_width, "Bin");

By the way, it would flow much better, I think, if we used the short-and-sweet variable name `padding` instead of `num_padding_spaces`.

Show 13 quoted lines
>  			if (!added && !deleted) {
>  				strbuf_addch(&out, '\n');
>  				emit_diff_symbol(options, DIFF_SYMBOL_STATS_LINE,
> @@ -2776,8 +2781,10 @@ static void show_stats(struct diffstat_t *data, struct diff_options *options)
>  			continue;
>  		}
>  		else if (file->is_unmerged) {
> -			strbuf_addf(&out, " %s%-*s |", prefix, len, name);
> -			strbuf_addstr(&out, " Unmerged\n");
> +			strbuf_addf(&out, " %s%s ", prefix,  name);
> +			if (num_padding_spaces)
> +				strbuf_addchars(&out, ' ', num_padding_spaces);
> +			strbuf_addstr(&out, "| Unmerged\n");
This can become
			strbuf_addf(&out, " %s%s%*s | Unmerged",
				    prefix, name, padding, "");
instead.
Show 15 quoted lines
>  			emit_diff_symbol(options, DIFF_SYMBOL_STATS_LINE,
>  					 out.buf, out.len, 0);
>  			strbuf_reset(&out);
> @@ -2803,8 +2810,10 @@ static void show_stats(struct diffstat_t *data, struct diff_options *options)
>  				add = total - del;
>  			}
>  		}
> -		strbuf_addf(&out, " %s%-*s |", prefix, len, name);
> -		strbuf_addf(&out, " %*"PRIuMAX"%s",
> +		strbuf_addf(&out, " %s%s ", prefix,  name);
> +		if (num_padding_spaces)
> +			strbuf_addchars(&out, ' ', num_padding_spaces);
> +		strbuf_addf(&out, "| %*"PRIuMAX"%s",
>  			number_width, added + deleted,
>  			added + deleted ? " " : "");
And this reads better as
		strbuf_addf(&out, " %s%s%*s | %*"PRIuMAX"%s",
			    prefix, name, padding, "",
			    number_width, added + deleted,
			    added + deleted ? " " : "");

If we modify the code in this manner, we avoid repeating a pretty unreadable pattern three times, using a much more readable pattern instead.

Random note: The existing code (not your fault) is hard to follow because it calls `show_graph()` for `add` and `del` always, even if their counts are zero (in which case `show_graph()` returns early), while the separating space is appended in the otherwise unrelated `strbuf_addf()` call before that, but uses the (unscaled) `added + deleted` as condition for that separator. It would be much easier to follow like this:

		strbuf_addf(&out, " %s%s%*s | %*"PRIuMAX",
			    prefix, name, padding, "",
			    number_width, added + deleted);
		if (add || del) {
			strbuf_addch(&out, ' ');
			show_graph(&out, '+', add, add_c, reset);
			show_graph(&out, '-', del, del_c, reset);
		}

But I consider this #leftoverbits, not something to burden your contribution with.

Ciao, Dscho

>  		show_graph(&out, '+', add, add_c, reset);
Previous: tboegi@web.deNext: tboegi@web.de
Message 24 of 42 in “[BUG] Unicode filenames handling in `git log --stat`”
  1. Alexander MeshcheryakovAug 9, 2022
  2. Calvin WanAug 9, 2022
  3. Alexander MeshcheryakovAug 9, 2022
  4. Calvin WanAug 9, 2022
  5. Junio C HamanoAug 10, 2022
  6. Torsten BögershausenAug 10, 2022
  7. Alexander MeshcheryakovAug 10, 2022
  8. Torsten BögershausenAug 10, 2022
  9. Torsten BögershausenAug 10, 2022
  10. Junio C HamanoAug 10, 2022
  11. Torsten BögershausenAug 10, 2022
  12. 1/1 diff.c: When appropriate, use utf8_strwidth()tboegi@web.de, Aug 14, 2022
  13. Junio C HamanoAug 14, 2022
  14. Torsten BögershausenAug 15, 2022
  15. Junio C HamanoAug 18, 2022
  16. 1/1 diff.c: When appropriate, use utf8_strwidth()tboegi@web.de, Aug 27, 2022
  17. Torsten BögershausenAug 27, 2022
  18. Eric SunshineAug 27, 2022
  19. Johannes SchindelinAug 29, 2022
  20. Torsten BögershausenAug 29, 2022
  21. Junio C HamanoAug 29, 2022
  22. Johannes SchindelinSep 2, 2022
  23. 2/2 diff.c: More changes and tests around utf8_strwidth()tboegi@web.de, Sep 2, 2022
  24. Johannes SchindelinSep 2, 2022
  25. 1/2 diff.c: When appropriate, use utf8_strwidth(), part1tboegi@web.de, Sep 2, 2022
  26. Johannes SchindelinSep 2, 2022
  27. 1/2 diff.c: When appropriate, use utf8_strwidth(), part1tboegi@web.de, Sep 3, 2022
  28. Junio C HamanoSep 5, 2022
  29. Torsten BögershausenSep 7, 2022
  30. Junio C HamanoSep 7, 2022
  31. 2/2 diff.c: More changes and tests around utf8_strwidth()tboegi@web.de, Sep 3, 2022
  32. Johannes SchindelinSep 5, 2022
  33. 1/1 diff.c: When appropriate, use utf8_strwidth()tboegi@web.de, Sep 14, 2022
  34. Junio C HamanoSep 14, 2022
  35. Torsten BögershausenSep 26, 2022
  36. Junio C HamanoOct 10, 2022
  37. Torsten BögershausenOct 20, 2022
  38. Junio C HamanoOct 20, 2022
  39. Torsten BögershausenOct 21, 2022
  40. Junio C HamanoOct 21, 2022
  41. Torsten BögershausenOct 23, 2022
  42. Junio C HamanoSep 15, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.