Victoria Dye
@vdye on GitHub. Posts as vdye@github.com.
748
messages
396
patches posted
97%
of 35 series merged
35
threads started
2021
first message, Sep 30, 2021
Feb 19, 2026
since the latest message
Patch series
Of 35 patch series (re-rolls counted once), 34 landed on master and 1 did not.
- mergedcat-file: add %(objectmode) and submodule message to batch commandsJun 2, 2025, 9fd38038b9
- not mergedmktree: support more flexible usagev2, Jun 19, 2024
- mergedDocumentation/git-merge-tree.txt: document -XMay 7, 2024, 2566a77774
- mergedref-filter.c: sort formatted dates by byte valueFeb 8, 2024, 46176d77c9
- mergedStrengthen fsck checks for submodule URLsv2, Jan 18, 2024, 13320ff610
- mergedfor-each-ref optimizations & usability improvementsv2, Nov 14, 2023, 56d26ade97
- mergedglossary: add definitions for dereference & peelv2, Nov 13, 2023, 893dce2ffb
- mergedPerformance improvement & cleanup in loose ref iterationv2, Oct 9, 2023, 5305474ec4
- mergedFix behavior of worktree config in submodulesv2, May 26, 2023, 847d0027d2
- mergedSkip 'cache_tree_update()' when 'prime_cache_tree()' is called immediate afterv3, Nov 10, 2022, 94fcf0e852
- mergedrebase --update-refs: avoid unintended ref deletionv2, Nov 7, 2022, 44da9e0841
- mergedread-cache: avoid misaligned reads in index v4v2, Sep 28, 2022, 4a6ed30f96
A series is merged when one of its patches matches a commit on master by the same author, by subject. Versions are linked when they share a patch subject. Patches reworded before landing, or applied under someone else's name, count as not merged.
Recent emails
- Re: [PATCH] t1006: fix %(rest) test for object names with whitespace
- Re: [PATCH 3/3] cat-file.c: add batch handling for submodules
- cat-file.c: add batch handling for submodules
- cat-file: add %(objectmode) atom
- t1006: update 'run_tests' to test generic object specifiers
- cat-file: add %(objectmode) and submodule message to batch commands
- Re: What's cooking in git.git (Jul 2024, #04; Fri, 12)
- mktree: remove entries when mode is 0
- mktree: allow deeper paths in input
- mktree: optionally add to an existing tree
- mktree: add directory-file conflict hashmap
- mktree: use iterator struct to add tree entries to index
- mktree: create tree using an in-core index
- mktree: overwrite duplicate entries
- mktree: validate paths more carefully
- mktree: add a --literally option
- mktree: use read_index_info to read stdin lines
- mktree.c: do not fail on mismatched submodule type
- index-info.c: return unrecognized lines to caller
- index-info.c: parse object type in provided in read_index_info
- update-index: generalize 'read_index_info'
- mktree: use non-static tree_entry array
- mktree: rename treeent to tree_entry
- mktree: use OPT_BOOL
- mktree: support more flexible usage
- Re: [PATCH 05/16] index-info.c: identify empty input lines in read_index_info
- Re: [PATCH 14/16] mktree: optionally add to an existing tree
- Re: [PATCH 12/16] mktree: use iterator struct to add tree entries to index
- Re: [PATCH 09/16] mktree: validate paths more carefully
- Re: [PATCH 10/16] mktree: overwrite duplicate entries