I have a repo with multiple remotes, one of which no longer exists. When git-maintenance runs on it, it fails during the prefetch stage because that remote doesn’t exist anymore, and gives a mostly unhelpful error message:
$ git maintenance run --schedule=daily ERROR: Repository not found. fatal: Could not read from remote repository.
Please make sure you have the correct access rights and the repository exists. error: failed to prefetch remotes error: task 'prefetch' failed
I think that 1. git-maintenance should report which remote it’s encountering an error on 2. git-maintenance should continue fetching other remotes even if one fails
Now, on my system, the systemd timers for git-maintenance use git-for-each-repo. Not sure if that’s upstream behaviour or something Nix/home-manager does. But if it is upstream behaviour, it would also be great to report the repo the error comes from, since I basically had to guess right now which repo was erroring. Luckily I have only three repos under maintenance so that was fine.
Let me know if you agree that this should be done. I would be open to writing a patch (no promises though)
Anselm