threads / patch / 61442

patchci: update coverity runs_on_pool reference

Subject: [PATCH] ci: update coverity runs_on_pool reference

## tl;dr

2 messages between May 9, 2024 and May 10, 2024. Diffs are folded; open one to read it.

replies: 1people: 2as markdown or json

Jeff King· May 9, 2024, 16:15 UTC · lore

Commit 2d65e5b6a6 (ci: rename "runs_on_pool" to "distro", 2024-04-12) renamed this variable for the main CI workflow, as well as in the ci/ scripts. Because the coverity workflow also relies on those scripts to install dependencies, it needs to be updated, too. Without this patch, the coverity build fails because we lack libcurl.

Signed-off-by: Jeff King <peff@peff.net>
---
On top of ps/ci-test-with-jgit, though that is now in master.
 .github/workflows/coverity.yml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Show changes to .github/workflows/coverity.yml +1 −1
diff --git a/.github/workflows/coverity.yml b/.github/workflows/coverity.yml
index 53cf12fe04..48341e81f4 100644
--- a/.github/workflows/coverity.yml
+++ b/.github/workflows/coverity.yml
@@ -45,7 +45,7 @@ jobs:
       - run: ci/install-dependencies.sh
         if: contains(matrix.os, 'ubuntu') || contains(matrix.os, 'macos')
         env:
-          runs_on_pool: ${{ matrix.os }}
+          distro: ${{ matrix.os }}
 
       # The Coverity site says the tool is usually updated twice yearly, so the
       # MD5 of download can be used to determine whether there's been an update.
-- 
2.45.0.414.g4009e73179
Patrick Steinhardt· May 10, 2024, 04:31 UTC · re: Jeff King · lore

Re: [PATCH] ci: update coverity runs_on_pool reference

On Thu, May 09, 2024 at 12:15:06PM -0400, Jeff King wrote:
Show 5 quoted lines
> Commit 2d65e5b6a6 (ci: rename "runs_on_pool" to "distro", 2024-04-12)
> renamed this variable for the main CI workflow, as well as in the ci/
> scripts. Because the coverity workflow also relies on those scripts to
> install dependencies, it needs to be updated, too. Without this patch,
> the coverity build fails because we lack libcurl.

Ah, I missed that one. Thanks for the fix, which looks obviously good to me!

Patrick

← back to recent threads