# [PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file

3 messages from 2023-04-30 to 2023-05-01. Participants: Oswald Buddenhagen, Junio C Hamano.
Thread: https://gitlist.dev/t/59674

## Oswald Buddenhagen, 2023-04-30 10:00

Subject: [PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file
Message-ID: <20230430100034.1889796-1-oswald.buddenhagen@gmx.de>
URL: https://gitlist.dev/e/20230430100034.1889796-1-oswald.buddenhagen%40gmx.de

```
The file started out as a test for picks and reverts with renames, but
has been subsequently populated will all kinds of basic tests, in
accordance with its generic name. Adjust the description to reflect
that.

Signed-off-by: Oswald Buddenhagen <oswald.buddenhagen@gmx.de>
---
Cc: Junio C Hamano <gitster@pobox.com>
---
 t/t3501-revert-cherry-pick.sh | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

diff --git a/t/t3501-revert-cherry-pick.sh b/t/t3501-revert-cherry-pick.sh
index 2f3e3e2416..e2ef619323 100755
--- a/t/t3501-revert-cherry-pick.sh
+++ b/t/t3501-revert-cherry-pick.sh
@@ -1,14 +1,6 @@
 #!/bin/sh
 
-test_description='test cherry-pick and revert with renames
-
-  --
-   + rename2: renames oops to opos
-  +  rename1: renames oops to spoo
-  +  added:   adds extra line to oops
-  ++ initial: has lines in oops
-
-'
+test_description='miscellaneous basic tests for cherry-pick and revert'
 
 GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME=main
 export GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME
@@ -63,6 +55,14 @@ test_expect_success 'revert --nonsense' '
 	test_i18ngrep "[Uu]sage:" msg
 '
 
+# the following two test cherry-pick and revert with renames
+#
+# --
+#  + rename2: renames oops to opos
+# +  rename1: renames oops to spoo
+# +  added:   adds extra line to oops
+# ++ initial: has lines in oops
+
 test_expect_success 'cherry-pick after renaming branch' '
 
 	git checkout rename2 &&
-- 
2.40.0.152.g15d061e6df


```

## Oswald Buddenhagen, 2023-04-30 11:52

Subject: Re: [PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file
Message-ID: <ZE5WiFr7ChhymlOe@ugly>
URL: https://gitlist.dev/e/ZE5WiFr7ChhymlOe%40ugly
In-Reply-To: <20230430100034.1889796-1-oswald.buddenhagen@gmx.de>

```
On Sun, Apr 30, 2023 at 12:00:34PM +0200, Oswald Buddenhagen wrote:
>The file started out as a test for picks and reverts with renames, but
>has been subsequently populated will all kinds of basic tests, in
				 ^^^^
				 "with", obviously.

>accordance with its generic name. Adjust the description to reflect
>that.
>

```

## Junio C Hamano, 2023-05-01 15:24

Subject: Re: [PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file
Message-ID: <xmqqa5yo847q.fsf@gitster.g>
URL: https://gitlist.dev/e/xmqqa5yo847q.fsf%40gitster.g
In-Reply-To: <20230430100034.1889796-1-oswald.buddenhagen@gmx.de>

```
Oswald Buddenhagen <oswald.buddenhagen@gmx.de> writes:

> The file started out as a test for picks and reverts with renames, but
> has been subsequently populated will all kinds of basic tests, in
> accordance with its generic name. Adjust the description to reflect
> that.
>
> Signed-off-by: Oswald Buddenhagen <oswald.buddenhagen@gmx.de>
> ---

> -test_description='test cherry-pick and revert with renames
> ...
> +test_description='miscellaneous basic tests for cherry-pick and revert'

Looks good.

Will queue.

Thanks.

```
