# A suggestion: more readable human commands

3 messages from 2021-06-15 to 2021-06-15. Participants: it-developer@abelardolg.com, Bagas Sanjaya, Andreas Schwab.
Thread: https://gitlist.dev/t/55933

## it-developer@abelardolg.com, 2021-06-15 10:51

Subject: A suggestion: more readable human commands
Message-ID: <fa2e886dd03a26c945d9deffe6f96d48@abelardolg.com>
URL: https://gitlist.dev/e/fa2e886dd03a26c945d9deffe6f96d48%40abelardolg.com

```
Hi there,

I would like to suggest you a new improvement.

Why not adding a new layer of abstraction for commands or to make more 
explicitly the commands?

For instance:

To merge a single file from one branch to another:

git checkout <branch_name> <path_to_file> --patch

would be like more readable human like this:

git merge <path_file> to <dst_branch>

It uses a more natural language.

Best regards.

```

## Bagas Sanjaya, 2021-06-15 10:59

Subject: Re: A suggestion: more readable human commands
Message-ID: <c3855aea-6cbd-af30-7791-07c212c52bbd@gmail.com>
URL: https://gitlist.dev/e/c3855aea-6cbd-af30-7791-07c212c52bbd%40gmail.com
In-Reply-To: <fa2e886dd03a26c945d9deffe6f96d48@abelardolg.com>

```
On 15/06/21 17.51, it-developer@abelardolg.com wrote:
> Hi there,
> 
> I would like to suggest you a new improvement.
> 
> Why not adding a new layer of abstraction for commands or to make more 
> explicitly the commands?
> 
> For instance:
> 
> To merge a single file from one branch to another:
> 
> git checkout <branch_name> <path_to_file> --patch
> 
> would be like more readable human like this:
> 
> git merge <path_file> to <dst_branch>
> 
> It uses a more natural language.
> 
> Best regards.

What workflow you do so that you need to merge single file?

-- 
An old man doll... just what I always wanted! - Clara

```

## Andreas Schwab, 2021-06-15 11:55

Subject: Re: A suggestion: more readable human commands
Message-ID: <87o8c7wdes.fsf@igel.home>
URL: https://gitlist.dev/e/87o8c7wdes.fsf%40igel.home
In-Reply-To: <fa2e886dd03a26c945d9deffe6f96d48@abelardolg.com>

```
On Jun 15 2021, it-developer@abelardolg.com wrote:

> To merge a single file from one branch to another:
>
> git checkout <branch_name> <path_to_file> --patch
>
> would be like more readable human like this:
>
> git merge <path_file> to <dst_branch>

This is ambigous if a branch or tag named <path_file> or to exists, and
the usual disambiguation using -- will not work.

Andreas.

-- 
Andreas Schwab, schwab@linux-m68k.org
GPG Key fingerprint = 7578 EB47 D4E5 4D69 2510  2552 DF73 E780 A9DA AEC1
"And now for something completely different."

```
