# [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

5 messages from 2020-03-18 to 2020-03-18. Participants: Shourya Shukla, Derrick Stolee.
Thread: https://gitlist.dev/t/53017

## Shourya Shukla, 2020-03-18 09:58

Subject: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <20200318095842.27679-1-shouryashukla.oo@gmail.com>
URL: https://gitlist.dev/e/20200318095842.27679-1-shouryashukla.oo%40gmail.com

```
Subcommands in 'submodule--helper.c' which give a callback to other functions
have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
respectively.

The subcommand 'foreach' did not follow this convention and therefore had the naming of
the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb'
and 'FOREACH_CB_INIT' respectively.


Shourya Shukla (1):
  submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

-- 
2.20.1


```

## Shourya Shukla, 2020-03-18 09:58

Subject: [PATCH 1/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <20200318095842.27679-2-shouryashukla.oo@gmail.com>
URL: https://gitlist.dev/e/20200318095842.27679-2-shouryashukla.oo%40gmail.com
In-Reply-To: <20200318095842.27679-1-shouryashukla.oo@gmail.com>

```
In 'submodule--helper.c', the structures and macros for callbacks belonging
to any subcommand are named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
respectively.

This was an exception for the subcommand 'foreach' of the command
'submodule'. Rename the aforementioned structures and macros:
'struct foreach_cb' to 'struct cb_foreach' and 'CB_FOREACH_INIT'
to 'FOREACH_CB_INIT'.

Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com>
---
 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c
index 86a608eec1..1a4b391c88 100644
--- a/builtin/submodule--helper.c
+++ b/builtin/submodule--helper.c
@@ -444,19 +444,19 @@ static void for_each_listed_submodule(const struct module_list *list,
 		fn(list->entries[i], cb_data);
 }
 
-struct cb_foreach {
+struct foreach_cb {
 	int argc;
 	const char **argv;
 	const char *prefix;
 	int quiet;
 	int recursive;
 };
-#define CB_FOREACH_INIT { 0 }
+#define FOREACH_CB_INIT { 0 }
 
 static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 				       void *cb_data)
 {
-	struct cb_foreach *info = cb_data;
+	struct foreach_cb *info = cb_data;
 	const char *path = list_item->name;
 	const struct object_id *ce_oid = &list_item->oid;
 
@@ -557,7 +557,7 @@ static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 
 static int module_foreach(int argc, const char **argv, const char *prefix)
 {
-	struct cb_foreach info = CB_FOREACH_INIT;
+	struct foreach_cb info = FOREACH_CB_INIT;
 	struct pathspec pathspec;
 	struct module_list list = MODULE_LIST_INIT;
 
-- 
2.20.1


```

## Derrick Stolee, 2020-03-18 10:57

Subject: Re: [PATCH 1/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <f6ea8357-a5c3-169c-b3c6-9d1726e65859@gmail.com>
URL: https://gitlist.dev/e/f6ea8357-a5c3-169c-b3c6-9d1726e65859%40gmail.com
In-Reply-To: <20200318095842.27679-2-shouryashukla.oo@gmail.com>

```
On 3/18/2020 5:58 AM, Shourya Shukla wrote:
> In 'submodule--helper.c', the structures and macros for callbacks belonging
> to any subcommand are named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
> respectively.
> 
> This was an exception for the subcommand 'foreach' of the command
> 'submodule'. Rename the aforementioned structures and macros:
> 'struct foreach_cb' to 'struct cb_foreach' and 'CB_FOREACH_INIT'
> to 'FOREACH_CB_INIT'.

I believe your "<before> to <after>" statements are reversed.

> Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com>
> ---
>  builtin/submodule--helper.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c
> index 86a608eec1..1a4b391c88 100644
> --- a/builtin/submodule--helper.c
> +++ b/builtin/submodule--helper.c
> @@ -444,19 +444,19 @@ static void for_each_listed_submodule(const struct module_list *list,
>  		fn(list->entries[i], cb_data);
>  }
>  
> -struct cb_foreach {
> +struct foreach_cb {
>  	int argc;
>  	const char **argv;
>  	const char *prefix;
>  	int quiet;
>  	int recursive;
>  };
> -#define CB_FOREACH_INIT { 0 }
> +#define FOREACH_CB_INIT { 0 }
>  
>  static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
>  				       void *cb_data)
>  {
> -	struct cb_foreach *info = cb_data;
> +	struct foreach_cb *info = cb_data;
>  	const char *path = list_item->name;
>  	const struct object_id *ce_oid = &list_item->oid;
>  
> @@ -557,7 +557,7 @@ static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
>  
>  static int module_foreach(int argc, const char **argv, const char *prefix)
>  {
> -	struct cb_foreach info = CB_FOREACH_INIT;
> +	struct foreach_cb info = FOREACH_CB_INIT;
>  	struct pathspec pathspec;
>  	struct module_list list = MODULE_LIST_INIT;

Based on the description, I was worried this patch would be very large.
The fact that the change is so small makes this reasonable in isolation.

Thanks,
-Stolee


```

## Shourya Shukla, 2020-03-18 14:20

Subject: [PATCH v2 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <20200318142024.16681-1-shouryashukla.oo@gmail.com>
URL: https://gitlist.dev/e/20200318142024.16681-1-shouryashukla.oo%40gmail.com
In-Reply-To: <20200318095842.27679-1-shouryashukla.oo@gmail.com>

```
Subcommands in 'submodule--helper.c' which give a callback to other functions
have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
respectively.

The subcommand 'foreach' did not follow this convention and therefore had the naming of
the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb'
and 'FOREACH_CB_INIT' respectively.


Changes in v2:
	Reworded the commit message. The last statement was wrong.
	Changed it from: 
	"Rename the aforementioned structures and macros:
	'struct foreach_cb' to 'struct cb_foreach' and 'CB_FOREACH_INIT'
	to 'FOREACH_CB_INIT'."
	;to:
	"Rename the aforementioned structures and macros:
	'struct cb_foreach' to 'struct foreach_cb' and 'CB_FOREACH_INIT'
	to 'FOREACH_CB_INIT'."


Shourya Shukla (1):
  submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

-- 
2.20.1


```

## Shourya Shukla, 2020-03-18 14:20

Subject: [PATCH v2 1/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <20200318142024.16681-2-shouryashukla.oo@gmail.com>
URL: https://gitlist.dev/e/20200318142024.16681-2-shouryashukla.oo%40gmail.com
In-Reply-To: <20200318142024.16681-1-shouryashukla.oo@gmail.com>

```
In 'submodule--helper.c', the structures and macros for callbacks belonging
to any subcommand are named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
respectively.

This was an exception for the subcommand 'foreach' of the command
'submodule'. Rename the aforementioned structures and macros:
'struct cb_foreach' to 'struct foreach_cb' and 'CB_FOREACH_INIT'
to 'FOREACH_CB_INIT'.

Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com>
---
 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c
index 86a608eec1..1a4b391c88 100644
--- a/builtin/submodule--helper.c
+++ b/builtin/submodule--helper.c
@@ -444,19 +444,19 @@ static void for_each_listed_submodule(const struct module_list *list,
 		fn(list->entries[i], cb_data);
 }
 
-struct cb_foreach {
+struct foreach_cb {
 	int argc;
 	const char **argv;
 	const char *prefix;
 	int quiet;
 	int recursive;
 };
-#define CB_FOREACH_INIT { 0 }
+#define FOREACH_CB_INIT { 0 }
 
 static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 				       void *cb_data)
 {
-	struct cb_foreach *info = cb_data;
+	struct foreach_cb *info = cb_data;
 	const char *path = list_item->name;
 	const struct object_id *ce_oid = &list_item->oid;
 
@@ -557,7 +557,7 @@ static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 
 static int module_foreach(int argc, const char **argv, const char *prefix)
 {
-	struct cb_foreach info = CB_FOREACH_INIT;
+	struct foreach_cb info = FOREACH_CB_INIT;
 	struct pathspec pathspec;
 	struct module_list list = MODULE_LIST_INIT;
 
-- 
2.20.1


```
