threads / patch / 52340

patchrun-command: use prepare_git_cmd() in prepare_cmd()

Subject: [PATCH] run-command: use prepare_git_cmd() in prepare_cmd()

## tl;dr

One message between Nov 26, 2019 and Nov 26, 2019. Diffs are folded; open one to read it.

replies: 0people: 1as markdown or json

René Scharfe· Nov 26, 2019, 09:06 UTC · lore
Call prepare_git_cmd() instead of open-coding it.
Signed-off-by: René Scharfe <l.s.r@web.de>
---
 run-command.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
Show changes to run-command.c +1 −3
diff --git a/run-command.c b/run-command.c
index 3449db319b..9942f120a9 100644
--- a/run-command.c
+++ b/run-command.c
@@ -412,8 +412,7 @@ static int prepare_cmd(struct argv_array *out, const struct child_process *cmd)
 	argv_array_push(out, SHELL_PATH);

 	if (cmd->git_cmd) {
-		argv_array_push(out, "git");
-		argv_array_pushv(out, cmd->argv);
+		prepare_git_cmd(out, cmd->argv);
 	} else if (cmd->use_shell) {
 		prepare_shell_cmd(out, cmd->argv);
 	} else {
--
2.24.0

← back to recent threads