# [PATCH v2] git-submodule.sh: shorten submodule SHA-1s using rev-parse

3 messages from 2019-01-27 to 2019-01-28. Participants: Sven van Haastregt, Eric Sunshine, Junio C Hamano.
Thread: https://gitlist.dev/t/50336

## Sven van Haastregt, 2019-01-27 19:27

Subject: [PATCH v2] git-submodule.sh: shorten submodule SHA-1s using rev-parse
Message-ID: <20190127192740.8678-1-svenvh@gmail.com>
URL: https://gitlist.dev/e/20190127192740.8678-1-svenvh%40gmail.com

```
Until now, `git submodule summary` was always emitting 7-character
SHA-1s that have a higher chance of being ambiguous for larger
repositories.  Use `git rev-parse --short` instead, which will
determine suitable short SHA-1 lengths.

We cannot rely on always successfully invoking `git rev-parse` in the
submodule directory.  Keep the old method using `cut` as a fallback.

Signed-off-by: Sven van Haastregt <svenvh@gmail.com>
---

Differences since v1: Keep the old method using `cut` as a fallback.

 git-submodule.sh | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/git-submodule.sh b/git-submodule.sh
index 5e608f8bad..5bd724e63b 100755
--- a/git-submodule.sh
+++ b/git-submodule.sh
@@ -850,8 +850,16 @@ cmd_summary() {
 			;;
 		esac
 
+		# Ensure we have crudely abbreviated SHA-1s as fallback in case
+		# rev-parse fails to shorten the SHA-1s.
 		sha1_abbr_src=$(echo $sha1_src | cut -c1-7)
 		sha1_abbr_dst=$(echo $sha1_dst | cut -c1-7)
+
+		sha1_abbrev=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_src) &&
+		sha1_abbr_src=$sha1_abbrev
+		sha1_abbrev=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_dst) &&
+		sha1_abbr_dst=$sha1_abbrev
+
 		if test $status = T
 		then
 			blob="$(gettext "blob")"
-- 
2.20.1.dirty


```

## Eric Sunshine, 2019-01-27 23:46

Subject: Re: [PATCH v2] git-submodule.sh: shorten submodule SHA-1s using rev-parse
Message-ID: <CAPig+cRLLTYB=tVOY39dojLYZqoX=yxPRZY9fjo9z+5+P2BKKg@mail.gmail.com>
URL: https://gitlist.dev/e/CAPig%2BcRLLTYB%3DtVOY39dojLYZqoX%3DyxPRZY9fjo9z%2B5%2BP2BKKg%40mail.gmail.com
In-Reply-To: <20190127192740.8678-1-svenvh@gmail.com>

```
On Sun, Jan 27, 2019 at 2:28 PM Sven van Haastregt <svenvh@gmail.com> wrote:
> Until now, `git submodule summary` was always emitting 7-character
> SHA-1s that have a higher chance of being ambiguous for larger
> repositories.  Use `git rev-parse --short` instead, which will
> determine suitable short SHA-1 lengths.
>
> We cannot rely on always successfully invoking `git rev-parse` in the
> submodule directory.  Keep the old method using `cut` as a fallback.
>
> Signed-off-by: Sven van Haastregt <svenvh@gmail.com>
> ---
> diff --git a/git-submodule.sh b/git-submodule.sh
> @@ -850,8 +850,16 @@ cmd_summary() {
> +               # Ensure we have crudely abbreviated SHA-1s as fallback in case
> +               # rev-parse fails to shorten the SHA-1s.
>                 sha1_abbr_src=$(echo $sha1_src | cut -c1-7)
>                 sha1_abbr_dst=$(echo $sha1_dst | cut -c1-7)
> +
> +               sha1_abbrev=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_src) &&
> +               sha1_abbr_src=$sha1_abbrev
> +               sha1_abbrev=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_dst) &&
> +               sha1_abbr_dst=$sha1_abbrev

This could be made a bit easier to follow by using indentation and ||
rather than &&. For instance, rewriting the entire block as:

    # Shorten with hard-coded fallback if rev-parse fails
    sha1_abbr_src=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_src ||
        echo $sha1_src | cut -c1-7)
    sha1_abbr_dst=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_dst ||
        echo $sha1_dst | cut -c1-7)

In fact, the code is clear enough that the comment isn't even needed.

By the way, if git-rev-parse does fail, is it going to produce an
error message on stderr that needs to be suppressed?

```

## Junio C Hamano, 2019-01-28 02:33

Subject: Re: [PATCH v2] git-submodule.sh: shorten submodule SHA-1s using rev-parse
Message-ID: <xmqqy375bjen.fsf@gitster-ct.c.googlers.com>
URL: https://gitlist.dev/e/xmqqy375bjen.fsf%40gitster-ct.c.googlers.com
In-Reply-To: <CAPig+cRLLTYB=tVOY39dojLYZqoX=yxPRZY9fjo9z+5+P2BKKg@mail.gmail.com>

```
Eric Sunshine <sunshine@sunshineco.com> writes:

> This could be made a bit easier to follow by using indentation and ||
> rather than &&. For instance, rewriting the entire block as:
>
>     # Shorten with hard-coded fallback if rev-parse fails
>     sha1_abbr_src=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_src ||
>         echo $sha1_src | cut -c1-7)
>     sha1_abbr_dst=$(GIT_DIR="$name/.git" git rev-parse --short $sha1_dst ||
>         echo $sha1_dst | cut -c1-7)
>
> In fact, the code is clear enough that the comment isn't even needed.
>
> By the way, if git-rev-parse does fail, is it going to produce an
> error message on stderr that needs to be suppressed?

All good points ;-).

```
