threads / discuss / 49322

Re: What's cooking in git.git (Sep 2018, #02; Tue, 11)

Subject: Re: What's cooking in git.git (Sep 2018, #02; Tue, 11)

## tl;dr

3 messages between Sep 12, 2018 and Sep 12, 2018.

replies: 2people: 2as markdown or json

Stephen & Linda Smith· Sep 12, 2018, 02:36 UTC · lore
On Tuesday, September 11, 2018 3:20:19 PM MST Junio C Hamano wrote:
Show 12 quoted lines
> 
> * jc/wt-status-state-cleanup (2018-09-07) 1 commit
>  - WIP: roll wt_status_state into wt_status and populate in the collect
> phase (this branch uses ss/wt-status-committable.)
> 
> * ss/wt-status-committable (2018-09-07) 4 commits
>  - wt-status.c: set the committable flag in the collect phase
>  - t7501: add test of "commit --dry-run --short"
>  - wt-status: rename commitable to committable
>  - wt-status.c: move has_unmerged earlier in the file
>  (this branch is used by jc/wt-status-state-cleanup.)
> 

I note that the jc/wt-status-state-cleanup branch is a patch "for illustration purposes only" [1].

I was about to update that patch to start dealing with the free() function calls, but noted you added the patch. Do you want me to take that patch and continue on? Or does someone else have something in progress?

sps

[1] https://public-inbox.org/git/20180906005329.11277-1-ischis2@cox.net/T/ #m3554b678d23fd8d7bc702d83667bebacdf02d8aa

Junio C Hamano· Sep 12, 2018, 07:13 UTC · re: Stephen & Linda Smith · lore
Stephen & Linda Smith <ischis2@cox.net> writes:
Show 20 quoted lines
> On Tuesday, September 11, 2018 3:20:19 PM MST Junio C Hamano wrote:
>> 
>> * jc/wt-status-state-cleanup (2018-09-07) 1 commit
>>  - WIP: roll wt_status_state into wt_status and populate in the collect
>> phase (this branch uses ss/wt-status-committable.)
>> 
>> * ss/wt-status-committable (2018-09-07) 4 commits
>>  - wt-status.c: set the committable flag in the collect phase
>>  - t7501: add test of "commit --dry-run --short"
>>  - wt-status: rename commitable to committable
>>  - wt-status.c: move has_unmerged earlier in the file
>>  (this branch is used by jc/wt-status-state-cleanup.)
>> 
>
> I note that the jc/wt-status-state-cleanup branch is a patch "for illustration 
> purposes only" [1].
>
> I was about to update that patch to start dealing with the free() function 
> calls, but noted you added the patch.  Do you want me to take that patch and 
> continue on?  Or does someone else have something in progress?

I do not plan to. In general, anything that is only in 'pu' is a fair game---when a better alternative appears, or a discussion leads to a conclusion that a change is unneeded, they are replaced and/or discarded. Just think of them as being kept slightly better record of existence than merely being in the list archive, nothing more.

Stephen & Linda Smith· Sep 12, 2018, 11:39 UTC · re: Stephen & Linda Smith · lore
On Wednesday, September 12, 2018 12:13:23 AM MST Junio C Hamano wrote:
Show 24 quoted lines
> Stephen & Linda Smith <ischis2@cox.net> writes:
> > On Tuesday, September 11, 2018 3:20:19 PM MST Junio C Hamano wrote:
> >> * jc/wt-status-state-cleanup (2018-09-07) 1 commit
> >> 
> >>  - WIP: roll wt_status_state into wt_status and populate in the collect
> >> 
> >> phase (this branch uses ss/wt-status-committable.)
> >> 
> >> * ss/wt-status-committable (2018-09-07) 4 commits
> >> 
> >>  - wt-status.c: set the committable flag in the collect phase
> >>  - t7501: add test of "commit --dry-run --short"
> >>  - wt-status: rename commitable to committable
> >>  - wt-status.c: move has_unmerged earlier in the file
> >>  (this branch is used by jc/wt-status-state-cleanup.)
> > 
> > I note that the jc/wt-status-state-cleanup branch is a patch "for
> > illustration purposes only" [1].
> > 
> > I was about to update that patch to start dealing with the free() function
> > calls, but noted you added the patch.  Do you want me to take that patch
> > and continue on?  Or does someone else have something in progress?
> 
> I do not plan to.  

Ok ... from the wording I wasn't sure if there wasn't another developer working this. I will pick up that patch and continue.

Show 5 quoted lines
> In general, anything that is only in 'pu' is a
> fair game---when a better alternative appears, or a discussion leads
> to a conclusion that a change is unneeded, they are replaced and/or
> discarded.  Just think of them as being kept slightly better record
> of existence than merely being in the list archive, nothing more.
Thanks that confirmed my reading of the Documentation/gitworkflows.txt.

← back to recent threads