threads / patch / 42669

patcht5614: don't use subshells

Subject: [PATCH] t5614: don't use subshells

## tl;dr

4 messages between Jun 20, 2016 and Jun 21, 2016. Diffs are folded; open one to read it.

replies: 3people: 3as markdown or json

Stefan Beller· Jun 20, 2016, 17:21 UTC · lore

Using a subshell for just one git command is both a waste in compute overhead (create a new process) as well as in line count.

Suggested-by: Jeff King <peff@peff.net>
Signed-off-by: Stefan Beller <sbeller@google.com>
---
 Junio,
 This goes on top of the patch that I just sent
 "[PATCH] shallow clone to not imply shallow submodules" (which is to
 be squashed into "clone: do not let --depth imply --shallow-submodules".
 
 Unlike the prior patch we would not want this patch to fall through
 to origin/maint fast, but allow cooking?
 
 Thanks,
 Stefan
 t/t5614-clone-submodules.sh | 70 +++++++++++++--------------------------------
 1 file changed, 20 insertions(+), 50 deletions(-)
Show changes to t/t5614-clone-submodules.sh +20 −50
diff --git a/t/t5614-clone-submodules.sh b/t/t5614-clone-submodules.sh
index a9aaa01..da2a67f 100755
--- a/t/t5614-clone-submodules.sh
+++ b/t/t5614-clone-submodules.sh
@@ -25,76 +25,46 @@ test_expect_success 'setup' '
 test_expect_success 'nonshallow clone implies nonshallow submodule' '
 	test_when_finished "rm -rf super_clone" &&
 	git clone --recurse-submodules "file://$pwd/." super_clone &&
-	(
-		cd super_clone &&
-		git log --oneline >lines &&
-		test_line_count = 3 lines
-	) &&
-	(
-		cd super_clone/sub &&
-		git log --oneline >lines &&
-		test_line_count = 3 lines
-	)
+	git -C super_clone log --oneline >lines &&
+	test_line_count = 3 lines &&
+	git -C super_clone/sub log --oneline >lines &&
+	test_line_count = 3 lines
 '
 
 test_expect_success 'shallow clone with shallow submodule' '
 	test_when_finished "rm -rf super_clone" &&
 	git clone --recurse-submodules --depth 2 --shallow-submodules "file://$pwd/." super_clone &&
-	(
-		cd super_clone &&
-		git log --oneline >lines &&
-		test_line_count = 2 lines
-	) &&
-	(
-		cd super_clone/sub &&
-		git log --oneline >lines &&
-		test_line_count = 1 lines
-	)
+	git -C super_clone log --oneline >lines &&
+	test_line_count = 2 lines &&
+	git -C super_clone/sub log --oneline >lines &&
+	test_line_count = 1 lines
 '
 
 test_expect_success 'shallow clone does not imply shallow submodule' '
 	test_when_finished "rm -rf super_clone" &&
 	git clone --recurse-submodules --depth 2 "file://$pwd/." super_clone &&
-	(
-		cd super_clone &&
-		git log --oneline >lines &&
-		test_line_count = 2 lines
-	) &&
-	(
-		cd super_clone/sub &&
-		git log --oneline >lines &&
-		test_line_count = 3 lines
-	)
+	git -C super_clone log --oneline >lines &&
+	test_line_count = 2 lines &&
+	git -C super_clone/sub log --oneline >lines &&
+	test_line_count = 3 lines
 '
 
 test_expect_success 'shallow clone with non shallow submodule' '
 	test_when_finished "rm -rf super_clone" &&
 	git clone --recurse-submodules --depth 2 --no-shallow-submodules "file://$pwd/." super_clone &&
-	(
-		cd super_clone &&
-		git log --oneline >lines &&
-		test_line_count = 2 lines
-	) &&
-	(
-		cd super_clone/sub &&
-		git log --oneline >lines &&
-		test_line_count = 3 lines
-	)
+	git -C super_clone log --oneline >lines &&
+	test_line_count = 2 lines &&
+	git -C super_clone/sub log --oneline >lines &&
+	test_line_count = 3 lines
 '
 
 test_expect_success 'non shallow clone with shallow submodule' '
 	test_when_finished "rm -rf super_clone" &&
 	git clone --recurse-submodules --no-local --shallow-submodules "file://$pwd/." super_clone &&
-	(
-		cd super_clone &&
-		git log --oneline >lines &&
-		test_line_count = 3 lines
-	) &&
-	(
-		cd super_clone/sub &&
-		git log --oneline >lines &&
-		test_line_count = 1 lines
-	)
+	git -C super_clone log --oneline >lines &&
+	test_line_count = 3 lines &&
+	git -C super_clone/sub log --oneline >lines &&
+	test_line_count = 1 lines
 '
 
 test_done
-- 
2.7.0.rc0.40.g5328432.dirty
Junio C Hamano· Jun 21, 2016, 19:18 UTC · re: Stefan Beller · lore

Re: [PATCH] t5614: don't use subshells

Stefan Beller <sbeller@google.com> writes:
>  Unlike the prior patch we would not want this patch to fall through
>  to origin/maint fast, but allow cooking?

I do not see anything that makes this treated differently from the other fix. The only difference in behaviour is that "lines" file is now created at the root level of the trash repository's working tree instead of tested clones', and I do not think any test depends on the number of untracked paths in the trash working tree or tries to make sure a file called "lines" is not in there.

Show 23 quoted lines
> diff --git a/t/t5614-clone-submodules.sh b/t/t5614-clone-submodules.sh
> index a9aaa01..da2a67f 100755
> --- a/t/t5614-clone-submodules.sh
> +++ b/t/t5614-clone-submodules.sh
> @@ -25,76 +25,46 @@ test_expect_success 'setup' '
>  test_expect_success 'nonshallow clone implies nonshallow submodule' '
>  	test_when_finished "rm -rf super_clone" &&
>  	git clone --recurse-submodules "file://$pwd/." super_clone &&
> -	(
> -		cd super_clone &&
> -		git log --oneline >lines &&
> -		test_line_count = 3 lines
> -	) &&
> -	(
> -		cd super_clone/sub &&
> -		git log --oneline >lines &&
> -		test_line_count = 3 lines
> -	)
> +	git -C super_clone log --oneline >lines &&
> +	test_line_count = 3 lines &&
> +	git -C super_clone/sub log --oneline >lines &&
> +	test_line_count = 3 lines
>  '

Having said that, I wonder if we want further reduction of the repetition. Each test except "setup" in this script does an identical thing with very small set of parameters:

    - make sure super_clone will be removed when done.
    - clone file://$pwd/. to super_clone but with different set of options.
    - check the commits in super_clone and super_clone/sub.
So, the above would ideally become something like
do_test 3 3 --recurse-submodules
where the helper would look like
do_test () {
	cnt_super=$1 cnt_sub=$2 &&
        shift 2 &&
        test_when_finished "rm -fr super_clone" &&
        git clone "$@" "file://$pwd/." super_clone &&
        git -C super_clone log --oneline >lines &&
        test_line_count = $cnt_super lines &&
        git -C super_clone/sub log --oneline >lines &&
        test_line_count = $cnt_sub lines
}

Would it rob too much flexibility from future tests to be added to this script if we did it that way?

Jeff King· Jun 21, 2016, 19:38 UTC · re: Junio C Hamano · lore

Re: [PATCH] t5614: don't use subshells

On Tue, Jun 21, 2016 at 12:18:29PM -0700, Junio C Hamano wrote:
Show 11 quoted lines
> Stefan Beller <sbeller@google.com> writes:
> 
> >  Unlike the prior patch we would not want this patch to fall through
> >  to origin/maint fast, but allow cooking?
> 
> I do not see anything that makes this treated differently from the
> other fix.  The only difference in behaviour is that "lines" file is
> now created at the root level of the trash repository's working tree
> instead of tested clones', and I do not think any test depends on
> the number of untracked paths in the trash working tree or tries to
> make sure a file called "lines" is not in there.

I think it is only that the other patch is actually fixing something, whereas this is cleanup. So the cost/benefit equation is different. I agree neither is high-risk and a test cleanup is generally OK for maint (the other is a serious-ish regression IMHO).

Show 27 quoted lines
> Having said that, I wonder if we want further reduction of the
> repetition.  Each test except "setup" in this script does an
> identical thing with very small set of parameters:
> 
>     - make sure super_clone will be removed when done.
>     - clone file://$pwd/. to super_clone but with different set of options.
>     - check the commits in super_clone and super_clone/sub.
> 
> So, the above would ideally become something like
> 
> do_test 3 3 --recurse-submodules
> 
> where the helper would look like
> 
> do_test () {
> 	cnt_super=$1 cnt_sub=$2 &&
>         shift 2 &&
>         test_when_finished "rm -fr super_clone" &&
>         git clone "$@" "file://$pwd/." super_clone &&
>         git -C super_clone log --oneline >lines &&
>         test_line_count = $cnt_super lines &&
>         git -C super_clone/sub log --oneline >lines &&
>         test_line_count = $cnt_sub lines
> }
> 
> Would it rob too much flexibility from future tests to be added to
> this script if we did it that way?

I think that's an improvement, too. Even if we add further tests, they don't have to follow the same format. I would give the function a better name than "do_test" though. :P

-Peff
Stefan Beller· Jun 21, 2016, 20:14 UTC · re: Jeff King · lore

Re: [PATCH] t5614: don't use subshells

On Tue, Jun 21, 2016 at 12:38 PM, Jeff King <peff@peff.net> wrote:
Show 18 quoted lines
> On Tue, Jun 21, 2016 at 12:18:29PM -0700, Junio C Hamano wrote:
>
>> Stefan Beller <sbeller@google.com> writes:
>>
>> >  Unlike the prior patch we would not want this patch to fall through
>> >  to origin/maint fast, but allow cooking?
>>
>> I do not see anything that makes this treated differently from the
>> other fix.  The only difference in behaviour is that "lines" file is
>> now created at the root level of the trash repository's working tree
>> instead of tested clones', and I do not think any test depends on
>> the number of untracked paths in the trash working tree or tries to
>> make sure a file called "lines" is not in there.
>
> I think it is only that the other patch is actually fixing something,
> whereas this is cleanup. So the cost/benefit equation is different. I
> agree neither is high-risk and a test cleanup is generally OK for maint
> (the other is a serious-ish regression IMHO).

I agree on the cost/benefit equation being different. I considered this patch a "normal risk" thing, which by our standards is not going through to maint directly, but is cooked at various heat levels before.

Show 32 quoted lines
>
>> Having said that, I wonder if we want further reduction of the
>> repetition.  Each test except "setup" in this script does an
>> identical thing with very small set of parameters:
>>
>>     - make sure super_clone will be removed when done.
>>     - clone file://$pwd/. to super_clone but with different set of options.
>>     - check the commits in super_clone and super_clone/sub.
>>
>> So, the above would ideally become something like
>>
>> do_test 3 3 --recurse-submodules
>>
>> where the helper would look like
>>
>> do_test () {
>>       cnt_super=$1 cnt_sub=$2 &&
>>         shift 2 &&
>>         test_when_finished "rm -fr super_clone" &&
>>         git clone "$@" "file://$pwd/." super_clone &&
>>         git -C super_clone log --oneline >lines &&
>>         test_line_count = $cnt_super lines &&
>>         git -C super_clone/sub log --oneline >lines &&
>>         test_line_count = $cnt_sub lines
>> }
>>
>> Would it rob too much flexibility from future tests to be added to
>> this script if we did it that way?
>
> I think that's an improvement, too. Even if we add further tests, they
> don't have to follow the same format. I would give the function a better
> name than "do_test" though. :P

I thought about implementing this, but I was unsure how much flexibility it is robbing, as we don't know in which direction we're going to extend the tests if at all. (Are we testing more options or do we want to inject more commands like "git submodule update --keep-configured-depth" ? That kept me away from doing the super short do_test)

Thanks, Stefan

>
> -Peff

← back to recent threads