The latest maintenance release Git v2.8.2 is now available at the usual places.
The tarballs are found at:
https://www.kernel.org/pub/software/scm/git/
The following public repositories all have a copy of the 'v2.8.2' tag and the 'maint' branch that the tag points at:
url = https://kernel.googlesource.com/pub/scm/git/git url = git://repo.or.cz/alt-git.git url = git://git.sourceforge.jp/gitroot/git-core/git.git url = git://git-core.git.sourceforge.net/gitroot/git-core/git-core url = https://github.com/gitster/git
----------------------------------------------------------------
Git v2.8.2 Release Notes ========================
Fixes since v2.8.1 ------------------
* The embedded args argv-array in the child process is used to build the command line to run pack-objects instead of using a separate array of strings.
* Bunch of tests on "git clone" has been renumbered for better organization.
* The tests that involve running httpd leaked the system-wide configuration in /etc/gitconfig to the tested environment.
* "index-pack --keep=<msg>" was broken since v2.1.0 timeframe.
* "git config --get-urlmatch", unlike other variants of the "git config --get" family, did not signal error with its exit status when there was no matching configuration.
* The "--local-env-vars" and "--resolve-git-dir" options of "git rev-parse" failed to work outside a repository when the command's option parsing was rewritten in 1.8.5 era.
* Fetching of history by naming a commit object name directly didn't work across remote-curl transport.
* A small memory leak in an error codepath has been plugged in xdiff code.
* strbuf_getwholeline() did not NUL-terminate the buffer on certain corner cases in its error codepath.
* The startup_info data, which records if we are working inside a repository (among other things), are now uniformly available to Git subcommand implementations, and Git avoids attempting to touch references when we are not in a repository.
* "git mergetool" did not work well with conflicts that both sides deleted.
* "git send-email" had trouble parsing alias file in mailrc format when lines in it had trailing whitespaces on them.
* When "git merge --squash" stopped due to conflict, the concluding "git commit" failed to read in the SQUASH_MSG that shows the log messages from all the squashed commits.
* "git merge FETCH_HEAD" dereferenced NULL pointer when merging nothing into an unborn history (which is arguably unusual usage, which perhaps was the reason why nobody noticed it).
* Build updates for MSVC.
* "git diff -M" used to work better when two originally identical files A and B got renamed to X/A and X/B by pairing A to X/A and B to X/B, but this was broken in the 2.0 timeframe.
* "git send-pack --all <there>" was broken when its command line option parsing was written in the 2.6 timeframe.
* When running "git blame $path" with unnormalized data in the index for the path, the data in the working tree was blamed, even though "git add" would not have changed what is already in the index, due to "safe crlf" that disables the line-end conversion. It has been corrected.
Also contains minor documentation updates and code clean-ups.
----------------------------------------------------------------
Changes since v2.8.1 are as follows:
Alexander Kuleshov (1):
submodule-config: use hashmap_iter_first()Christian Couder (1):
Documentation: talk about pager in api-trace.txtDavid Aguilar (2):
mergetool: support delete/delete conflicts
mergetool: honor tempfile configuration when resolving delete conflictsElia Pinto (1):
api-trace.txt: fix typoGabriel Souza Franco (2):
fetch-pack: fix object_id of exact sha1
fetch-pack: update the documentation for "<refs>..." argumentsJeff King (12):
t1515: add tests for rev-parse out-of-repo helpers
rev-parse: let some options run outside repository
strbuf_getwholeline: NUL-terminate getdelim buffer on error
setup: make startup_info available everywhere
setup: set startup_info->have_repository more reliably
remote: don't resolve HEAD in non-repository
mailmap: do not resolve blobs in a non-repository
grep: turn off gitlink detection for --no-index
use setup_git_directory() in test-* programs
send-email: ignore trailing whitespace in mailrc alias file
credential-cache--daemon: clarify "exit" action semantics
t/lib-httpd: pass through GIT_CONFIG_NOSYSTEM envJohannes Sixt (1):
Windows: shorten code by re-using convert_slashes()John Keeping (3):
config: fail if --get-urlmatch finds no value
Documentation/git-config: use bulleted list for exit codes
Documentation/git-config: fix --get-all descriptionJunio C Hamano (7):
index-pack: correct --keep[=<msg>]
index-pack: add a helper function to derive .idx/.keep filename
merge: fix NULL pointer dereference when merging nothing into void
Makefile: fix misdirected redirections
Start preparing for 2.8.2
Prepare for 2.8.2
Git 2.8.2Matthieu Moy (2):
lockfile: mark strings for translation
lockfile: improve error message when lockfile existsMichael Procter (1):
upload-pack: use argv_array for pack_objectsNguyễn Thái Ngọc Duy (2):
git-apply.txt: remove a space
git-apply.txt: mention the behavior inside a subdirOri Avtalion (1):
Documentation: git diff --check detects conflict markersPranit Bauva (2):
t/t7502 : drop duplicate test
api-parse-options.txt: document OPT_CMDMODE()Ramsay Jones (2):
xdiff/xprepare: use the XDF_DIFF_ALG() macro to access flag bits
xdiff/xprepare: fix a memory leakSZEDER Gábor (1):
diffcore: fix iteration order of identical files during rename detectionSaurav Sachidanand (1):
dir: store EXC_FLAG_* values in unsigned integersStanislav Kolotinskiy (1):
git-send-pack: fix --all option when used with directoryStefan Beller (1):
clone tests: rename t57* => t56*Sven Strickroth (3):
commit: do not lose SQUASH_MSG contents
MSVC: vsnprintf in Visual Studio 2015 doesn't need SNPRINTF_SIZE_CORR any more
MSVC: use shipped headers instead of fallback definitionsTorsten Bögershausen (1):
correct blame for files commited with CRLFVasco Almeida (4):
l10n: fr: fix transcation of "dir"
l10n: fr: fix wrongly translated option name
l10n: fr: change "id de clé" to match "id-clé"
l10n: fr: don't translate "merge" as a parameter