# cmd_struct

5 messages from 2015-05-13 to 2015-05-14. Participants: Thiago Farina, Jonathan Nieder, Junio C Hamano, Johannes Schindelin.
Thread: https://gitlist.dev/t/39333

## Thiago Farina, 2015-05-13 23:10

Subject: cmd_struct
Message-ID: <CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com>
URL: https://gitlist.dev/e/CACnwZYe5i3p0f7cvprya%3DVdhFnnMW_H%3DK18BFqjq_Qn86cjXeA%40mail.gmail.com

```
Hi,

Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?

I know "Why" question could come, but I prefer to not answer it if I can.

Regards,

-- 
Thiago Farina

```

## Jonathan Nieder, 2015-05-13 23:23

Subject: Re: cmd_struct
Message-ID: <20150513232348.GD5586@google.com>
URL: https://gitlist.dev/e/20150513232348.GD5586%40google.com
In-Reply-To: <CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com>

```
Hi,

Thiago Farina wrote:

> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?
>
> I know "Why" question could come, but I prefer to not answer it if I can.

The answer depends on the "why".  (Not "why do you ask?", but "why
rename --- what benefit would it bring?")

Thanks and hope that helps,
Jonathan

```

## Junio C Hamano, 2015-05-13 23:24

Subject: Re: cmd_struct
Message-ID: <CAPc5daUF1SaCOqb0iEZ527q-CgQn3YyMSWufOsQx9Lo1+aUBrg@mail.gmail.com>
URL: https://gitlist.dev/e/CAPc5daUF1SaCOqb0iEZ527q-CgQn3YyMSWufOsQx9Lo1%2BaUBrg%40mail.gmail.com
In-Reply-To: <CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com>

```
On Wed, May 13, 2015 at 4:10 PM, Thiago Farina <tfransosi@gmail.com> wrote:
>
> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?

The name has served us well, I do not see a compelling reason to change it
to anything else, and I suspect the name stayed unchanged because nobody
else found such a reason, either.

So... if you are unwilling to make a compelling case telling us why the current
name does not work, I do not think it is likely that anybody finds such a change
necessary, welcome, or even tolerable.

```

## Junio C Hamano, 2015-05-13 23:31

Subject: Re: cmd_struct
Message-ID: <xmqq617w9hr1.fsf@gitster.dls.corp.google.com>
URL: https://gitlist.dev/e/xmqq617w9hr1.fsf%40gitster.dls.corp.google.com
In-Reply-To: <CAPc5daUF1SaCOqb0iEZ527q-CgQn3YyMSWufOsQx9Lo1+aUBrg@mail.gmail.com>

```
Junio C Hamano <gitster@pobox.com> writes:

> On Wed, May 13, 2015 at 4:10 PM, Thiago Farina <tfransosi@gmail.com> wrote:
>>
>> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?
>
> The name has served us well, I do not see a compelling reason to change it
> to anything else, and I suspect the name stayed unchanged because nobody
> else found such a reason, either.
>
> So... if you are unwilling to make a compelling case telling us why the current
> name does not work, I do not think it is likely that anybody finds such a change
> necessary, welcome, or even tolerable.

Having said that, I would agree that if I were writing git.c from
scratch today, I would have done

	static struct builtin_cmd builtin_cmd[] = { ...

insead of the current

	static struct cmd_struct commands[] = { ...

just because I think it makes more sense.  But that reason suggests
it is a mere code churn of no value, after all these years.

"Because the non-POSIX non-ANSI-C platform I am porting for stomps
on the end-user program's namespace, and cmd_struct is one of the
victims" could be a reason that is better than "just because I think
it makes more sense", but even then, there would probably be a
better ways other than renaming the symbols in end-user code
(i.e. Git) to solve such a name clash.

```

## Johannes Schindelin, 2015-05-14 07:49

Subject: Re: cmd_struct
Message-ID: <5da49038cab4173e8e11e698aeb3410a@www.dscho.org>
URL: https://gitlist.dev/e/5da49038cab4173e8e11e698aeb3410a%40www.dscho.org
In-Reply-To: <CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com>

```
Hi Thiago,

On 2015-05-14 01:10, Thiago Farina wrote:

> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?
> 
> I know "Why" question could come, but I prefer to not answer it if I can.

It would be too much churn/noise, but I prefer not to describe why, if I can.

*grins*

Ciao,
Dscho

```
