threads / patch / 37605

patch, 2 partsgraph: simplify graph_padding_line()

Subject: [PATCH 1/2] graph: simplify graph_padding_line()

## tl;dr

2 messages between Sep 20, 2014 and Sep 20, 2014. Diffs are folded; open one to read it.

replies: 1people: 1as markdown or json

René Scharfe· Sep 20, 2014, 18:29 UTC · lore
Deduplicate code common to both branches of if statements.
Signed-off-by: Rene Scharfe <l.s.r@web.de>
---
 graph.c | 17 ++++-------------
 1 file changed, 4 insertions(+), 13 deletions(-)
Show changes to graph.c +4 −13
diff --git a/graph.c b/graph.c
index dfb99f6..52605e4 100644
--- a/graph.c
+++ b/graph.c
@@ -1161,20 +1161,11 @@ static void graph_padding_line(struct git_graph *graph, struct strbuf *sb)
 	 */
 	for (i = 0; i < graph->num_columns; i++) {
 		struct column *col = &graph->columns[i];
-		struct commit *col_commit = col->commit;
-		if (col_commit == graph->commit) {
-			strbuf_write_column(sb, col, '|');
-
-			if (graph->num_parents < 3)
-				strbuf_addch(sb, ' ');
-			else {
-				int num_spaces = ((graph->num_parents - 2) * 2);
-				strbuf_addchars(sb, ' ', num_spaces);
-			}
-		} else {
-			strbuf_write_column(sb, col, '|');
+		strbuf_write_column(sb, col, '|');
+		if (col->commit == graph->commit && graph->num_parents > 2)
+			strbuf_addchars(sb, ' ', (graph->num_parents - 2) * 2);
+		else
 			strbuf_addch(sb, ' ');
-		}
 	}
 
 	graph_pad_horizontally(graph, sb, graph->num_columns);
-- 
2.1.1
René Scharfe· Sep 20, 2014, 21:35 UTC · re: René Scharfe · lore

Re: [PATCH 1/2] graph: simplify graph_padding_line()

Am 20.09.2014 um 20:29 schrieb René Scharfe:
> Deduplicate code common to both branches of if statements.
There is no 2/2, this patch is the only one at this time.
René

← back to recent threads