threads / patch / 37137

patchannotate: use argv_array

Subject: [PATCH] annotate: use argv_array

## tl;dr

One message between Jul 16, 2014 and Jul 16, 2014. Diffs are folded; open one to read it.

replies: 0people: 1as markdown or json

René Scharfe· Jul 16, 2014, 08:51 UTC · lore

Simplify the code and get rid of some magic constants by using argv_array to build the argument list for cmd_blame. Be lazy and let the OS release our allocated memory, as before.

Signed-off-by: Rene Scharfe <l.s.r@web.de>
---
 builtin/annotate.c | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)
Show changes to builtin/annotate.c +5 −7
diff --git a/builtin/annotate.c b/builtin/annotate.c
index fc43eed..da413ae 100644
--- a/builtin/annotate.c
+++ b/builtin/annotate.c
@@ -5,20 +5,18 @@
  */
 #include "git-compat-util.h"
 #include "builtin.h"
+#include "argv-array.h"
 
 int cmd_annotate(int argc, const char **argv, const char *prefix)
 {
-	const char **nargv;
+	struct argv_array args = ARGV_ARRAY_INIT;
 	int i;
-	nargv = xmalloc(sizeof(char *) * (argc + 2));
 
-	nargv[0] = "annotate";
-	nargv[1] = "-c";
+	argv_array_pushl(&args, "annotate", "-c", NULL);
 
 	for (i = 1; i < argc; i++) {
-		nargv[i+1] = argv[i];
+		argv_array_push(&args, argv[i]);
 	}
-	nargv[argc + 1] = NULL;
 
-	return cmd_blame(argc + 1, nargv, prefix);
+	return cmd_blame(args.argc, args.argv, prefix);
 }
-- 
2.0.0

← back to recent threads